Bug 29011 - Build fix when USE(LOCKFREE_THREADSAFESHARED) is not defined
: Build fix when USE(LOCKFREE_THREADSAFESHARED) is not defined
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Platform
: 528+ (Nightly build)
: PC Other
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks: 27065
  Show dependency treegraph
 
Reported: 2009-09-07 08:11 PDT by Laszlo Gombos
Modified: 2009-10-01 09:35 PDT (History)
3 users (show)

See Also:


Attachments
proposed patch. (1.11 KB, patch)
2009-09-07 08:17 PDT, Laszlo Gombos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Laszlo Gombos 2009-09-07 08:11:18 PDT
Some WebKit ports (e.g. Symbian QtWebKit port) does not (yet) define atomicIncrement and atomicDecrement functions. This is a "supported" configuration and the USE(LOCKFREE_THREADSAFESHARED) is used to determine if atomicIncrement and atomicDecrement functions are available.

ChangeSet http://trac.webkit.org/changeset/47845 introduced a change in Threading.h which would require to implement atomicIncrement and atomicDecrement functions for all ports. Guarding some of the changes in Threading.h with USE(LOCKFREE_THREADSAFESHARED) would fix this problem (and would fix the Symbian QtWebKit build). Patch will follow.
Comment 1 Laszlo Gombos 2009-09-07 08:17:40 PDT
Created attachment 39148 [details]
proposed patch.
Comment 2 Simon Hausmann 2009-09-07 09:40:17 PDT
Comment on attachment 39148 [details]
proposed patch.

r=me
Comment 3 Mark Rowe (bdash) 2009-09-08 03:29:04 PDT
*** Bug 29028 has been marked as a duplicate of this bug. ***
Comment 4 Eric Seidel 2009-09-08 08:23:45 PDT
Comment on attachment 39148 [details]
proposed patch.

Exception: Unknown committer: laszlo.1.gombos@nokia.com

If you're a committer, please make sure you're in LayoutTests/WebKitTools/Scripts/modules/committers.py
Comment 5 Laszlo Gombos 2009-09-08 09:14:16 PDT
Comment on attachment 39148 [details]
proposed patch.

Thanks Eric !

Added myself to list of committers -- http://trac.webkit.org/changeset/48159.

Let's try the commit-queue again.
Comment 6 Eric Seidel 2009-09-08 10:15:09 PDT
Comment on attachment 39148 [details]
proposed patch.

Clearing flags on attachment: 39148

Committed r48161: <http://trac.webkit.org/changeset/48161>
Comment 7 Eric Seidel 2009-09-08 10:15:15 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Mark Rowe (bdash) 2009-09-10 15:29:01 PDT
*** Bug 29149 has been marked as a duplicate of this bug. ***