Bug 28798 - [Gtk] does not compile with JIT on 64bit Linux
Summary: [Gtk] does not compile with JIT on 64bit Linux
Status: RESOLVED DUPLICATE of bug 28422
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-27 23:22 PDT by Yusuke Sato
Modified: 2009-08-27 23:59 PDT (History)
0 users

See Also:


Attachments
plt_fix_v1 (1.47 KB, patch)
2009-08-27 23:51 PDT, Yusuke Sato
mrowe: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Sato 2009-08-27 23:22:35 PDT
Original report: https://lists.webkit.org/pipermail/webkit-dev/2009-July/008930.html

$ ./WebKitTools/Scripts/build-webkit --gtk --debug
...
/usr/bin/ld: ./.libs/libJavaScriptCore.a(libJavaScriptCore_la-JITStubs.o): relocation R_X86_64_PC32 against `cti_vm_throw' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[1]: *** [libwebkit-1.0.la] Error 1
make[1]: Leaving directory `/usr/local/google/home/yusukes/WebKit/WebKitBuild/Debug'
make: *** [all] Error 2

The libJavaScriptCore_la-JITStubs.o IS compiled with -fPIC, however inline assembly code inside the source seems not to be PIC compatible. Note that release build doesn't have any problems since the assembly code in question is not used in the release build.
Comment 1 Yusuke Sato 2009-08-27 23:51:06 PDT
Created attachment 38717 [details]
plt_fix_v1


---
 2 files changed, 15 insertions(+), 2 deletions(-)
Comment 2 Mark Rowe (bdash) 2009-08-27 23:52:04 PDT
Comment on attachment 38717 [details]
plt_fix_v1

This will break the Mac build.  I'm sure we already have a bug about this too.
Comment 3 Mark Rowe (bdash) 2009-08-27 23:55:12 PDT

*** This bug has been marked as a duplicate of bug 28422 ***
Comment 4 Yusuke Sato 2009-08-27 23:59:36 PDT
Ah, sorry. I overlooked the bug 28422.