Bug 28656 - REGRESSION: r47676 hangs when loading page on Leopard/PPC
Summary: REGRESSION: r47676 hangs when loading page on Leopard/PPC
Status: RESOLVED DUPLICATE of bug 28655
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac (PowerPC) OS X 10.5
: P1 Blocker
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-22 11:19 PDT by Jon
Modified: 2009-08-22 14:07 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon 2009-08-22 11:19:00 PDT
Since my build last night, I've been getting this hang when trying to use ToT in Safari on Leopard/PPC.

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000008
Crashed Thread:  0

Thread 0 Crashed:
0   com.apple.JavaScriptCore      	0x00523630 JSC::JSFunction::~JSFunction() + 48
1   com.apple.JavaScriptCore      	0x0060e6a8 JSC::VPtrSet::VPtrSet() + 584
2   com.apple.JavaScriptCore      	0x0060e6a8 JSC::VPtrSet::VPtrSet() + 584
3   com.apple.JavaScriptCore      	0x0060f6a0 JSC::JSGlobalData::createLeaked() + 32 (JSGlobalData.cpp:105)
4   com.apple.WebCore             	0x019d7ecc WebCore::JSDOMWindowBase::commonJSGlobalData() + 44 (JSDOMWindowBase.cpp:168)
5   com.apple.WebCore             	0x019e20c4 WebCore::JSDOMWindowShell::operator new(unsigned long) + 20 (JSDOMWindowShell.cpp:152)
6   com.apple.WebCore             	0x01d92474 WebCore::ScriptController::initScript() + 68 (ScriptController.cpp:162)
7   com.apple.WebCore             	0x01d92984 WebCore::ScriptController::evaluate(WebCore::ScriptSourceCode const&) + 340 (ScriptController.h:143)
8   com.apple.WebCore             	0x017ebfb8 WebCore::FrameLoader::executeScript(WebCore::ScriptSourceCode const&) + 392 (FrameLoader.cpp:765)
9   com.apple.WebCore             	0x018a8494 WebCore::HTMLTokenizer::scriptExecution(WebCore::ScriptSourceCode const&, WebCore::HTMLTokenizer::State) + 932 (HTMLTokenizer.cpp:561)
10  com.apple.WebCore             	0x018a9224 WebCore::HTMLTokenizer::scriptHandler(WebCore::HTMLTokenizer::State) + 3380 (HTMLTokenizer.cpp:503)
11  com.apple.WebCore             	0x018a98cc WebCore::HTMLTokenizer::parseNonHTMLText(WebCore::SegmentedString&, WebCore::HTMLTokenizer::State) + 476 (HTMLTokenizer.cpp:350)
12  com.apple.WebCore             	0x018ac840 WebCore::HTMLTokenizer::parseTag(WebCore::SegmentedString&, WebCore::HTMLTokenizer::State) + 10304 (HTMLTokenizer.cpp:1520)
13  com.apple.WebCore             	0x018ad2d4 WebCore::HTMLTokenizer::write(WebCore::SegmentedString const&, bool) + 1204 (HTMLTokenizer.cpp:1748)
14  com.apple.WebCore             	0x017f1f60 WebCore::FrameLoader::write(char const*, int, bool) + 1424 (FrameLoader.cpp:1020)
15  com.apple.WebKit              	0x003209d8 -[WebFrame(WebInternal) _receivedData:textEncodingName:] + 312 (WebFrame.mm:981)
16  com.apple.WebKit              	0x003384ec -[WebHTMLRepresentation receivedData:withDataSource:] + 124 (WebHTMLRepresentation.mm:162)
17  com.apple.WebKit              	0x003109b4 -[WebDataSource(WebInternal) _receivedData:] + 84 (WebDataSource.mm:222)
18  com.apple.WebKit              	0x003279b4 WebFrameLoaderClient::committedLoad(WebCore::DocumentLoader*, char const*, int) + 116 (WebFrameLoaderClient.mm:801)
19  com.apple.WebCore             	0x016cd798 WebCore::DocumentLoader::commitLoad(char const*, int) + 88 (DocumentLoader.cpp:342)
20  com.apple.WebCore             	0x01d7c4a4 WebCore::ResourceLoader::didReceiveData(char const*, int, long long, bool) + 68 (ResourceLoader.cpp:247)
21  com.apple.WebCore             	0x01c2d9c4 WebCore::MainResourceLoader::didReceiveData(char const*, int, long long, bool) + 2324 (MainResourceLoader.cpp:352)
22  com.apple.Foundation          	0x94bbb2d4 _NSURLConnectionDidReceiveData + 136
23  com.apple.CFNetwork           	0x93cdbb48 URLConnectionClient::_clientDidReceiveData(__CFData const*, URLConnectionClient::ClientConnectionEventQueue*) + 256
24  com.apple.CFNetwork           	0x93cdcb0c URLConnectionClient::ClientConnectionEventQueue::processAllEventsAndConsumePayload(XConnectionEventInfo<XClientEvent, XClientEventParams>*, long) + 432
25  com.apple.CFNetwork           	0x93cdccd8 URLConnectionClient::ClientConnectionEventQueue::processAllEventsAndConsumePayload(XConnectionEventInfo<XClientEvent, XClientEventParams>*, long) + 892
26  com.apple.CFNetwork           	0x93cdb500 URLConnectionClient::processEvents() + 132
27  com.apple.CFNetwork           	0x93c85020 MultiplexerSource::perform() + 168
28  com.apple.CoreFoundation      	0x917950d0 CFRunLoopRunSpecific + 1104
29  com.apple.HIToolbox           	0x90033b14 RunCurrentEventLoopInMode + 264
30  com.apple.HIToolbox           	0x900338a0 ReceiveNextEventCommon + 260
31  com.apple.HIToolbox           	0x90033778 BlockUntilNextEventMatchingListInMode + 84
32  com.apple.AppKit              	0x92c08244 _DPSNextEvent + 596
33  com.apple.AppKit              	0x92c07bfc -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 112
34  com.apple.SafariTest          	0x0000db9c 0x1000 + 52124
35  com.apple.AppKit              	0x92c0189c -[NSApplication run] + 744
36  com.apple.AppKit              	0x92bd2298 NSApplicationMain + 440
37  com.apple.SafariTest          	0x00002fcc 0x1000 + 8140

Application launches fine, but when I try to load a page (I have it set to a blank page by default) it either freezes immediately, or after slightly loading the page. From the look of the trace, probably when it tries JS activity for the first time. I first noticed this problem at r47660.
Comment 1 Mark Rowe (bdash) 2009-08-22 14:07:14 PDT

*** This bug has been marked as a duplicate of bug 28655 ***