Bug 28609 - Buttons are not rendered correctly when scrolling page
Summary: Buttons are not rendered correctly when scrolling page
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL: https://bugs.webkit.org/query.cgi
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2009-08-21 03:13 PDT by Dimitris Apostolou
Modified: 2009-08-22 09:36 PDT (History)
2 users (show)

See Also:


Attachments
Attaching screenshot (297.04 KB, image/png)
2009-08-21 03:14 PDT, Dimitris Apostolou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitris Apostolou 2009-08-21 03:13:39 PDT
Steps:
1. Go to https://bugs.webkit.org/query.cgi
2. Scroll page to the bottom and then back to the top a few times.

What happened:
2. Buttons are not rendered correctly (see screenshot).

Expected result:
2. Buttons are rendered correctly.
Comment 1 Dimitris Apostolou 2009-08-21 03:14:49 PDT
Created attachment 38366 [details]
Attaching screenshot
Comment 2 Mark Rowe (bdash) 2009-08-21 03:38:31 PDT
I can reproduce this easily in the latest nightly build by resizing the window to be relatively short, giving lots of room for scrolling, scrolling to the bottom of the page, and then slowly scrolling back up.  The bottoms of <select> elements and buttons are not correctly painted.  This doesn't appear to happen in Safari 4.0.3.
Comment 3 Mark Rowe (bdash) 2009-08-21 03:39:20 PDT
<rdar://problem/7160138>
Comment 4 mitz 2009-08-21 07:14:11 PDT
(In reply to comment #2)
> I can reproduce this easily in the latest nightly buildr47546

> by resizing the window
> to be relatively short, giving lots of room for scrolling, scrolling to the
> bottom of the page, and then slowly scrolling back up.  The bottoms of <select>
> elements and buttons are not correctly painted.  This doesn't appear to happen
> in Safari 4.0.3.

I cannot reproduce in TOT. This sounds like the bug Hyatt fixed in <http://trac.webkit.org/changeset/47590>.
Comment 5 Dimitris Apostolou 2009-08-22 09:36:11 PDT
Verified with 6531.9, r47668

Closing.