Bug 28483 - [V8] ScriptController::cleanupScriptObjectsForPlugin should take a Widget* instead of void*
Summary: [V8] ScriptController::cleanupScriptObjectsForPlugin should take a Widget* in...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Darin Fisher (:fishd, Google)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-19 23:00 PDT by Darin Fisher (:fishd, Google)
Modified: 2009-08-20 00:31 PDT (History)
0 users

See Also:


Attachments
v1 patch (2.35 KB, patch)
2009-08-20 00:10 PDT, Darin Fisher (:fishd, Google)
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Fisher (:fishd, Google) 2009-08-19 23:00:02 PDT
[V8] ScriptController::cleanupScriptObjectsForPlugin should take a
Widget* instead of void*

This function is supposed to be called by the plugin when it goes
away.  It corresponds to createScriptInstanceForWidget, which takes
a Widget*.

As is, it is important for callers to cast to Widget* before calling
cleanupScriptObjectsForPlugin, which is rather error prone.

See http://codereview.chromium.org/174126 for example.
Comment 1 Darin Fisher (:fishd, Google) 2009-08-20 00:10:01 PDT
Created attachment 35188 [details]
v1 patch
Comment 2 Eric Seidel (no email) 2009-08-20 00:19:30 PDT
Comment on attachment 35188 [details]
v1 patch

LGTM.
Comment 3 Darin Fisher (:fishd, Google) 2009-08-20 00:31:48 PDT
Landed as:  http://trac.webkit.org/changeset/47556