Bug 28341 - REGRESSION (r47292): Prototype.js is broken by ES5 Arguments changes
Summary: REGRESSION (r47292): Prototype.js is broken by ES5 Arguments changes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Other
: P1 Critical
Assignee: Nobody
URL: http://www.me.com/mail
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2009-08-15 13:04 PDT by mitz
Modified: 2009-08-17 18:02 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2009-08-15 13:04:02 PDT
After logging in to MobileMe at www.me.com, it fails to load mail and remains stuck showing “Loading Mail…”. Contacts and Calendars behave similarly. The console shows the following:

TypeError: Result of expression 'SC.View.extend({click:function(){return true}}).outletFor' [undefined] is not a function.
TypeError: Result of expression 'Mac.PanelView' [undefined] is not an object.
TypeError: Result of expression 'SC.Page' [undefined] is not an object.
TypeError: Result of expression 'SC.Application' [undefined] is not an object.
Comment 1 mitz 2009-08-15 13:04:26 PDT
<rdar://problem/7145615>
Comment 2 Mark Rowe (bdash) 2009-08-15 15:45:34 PDT
Could be due to <http://trac.webkit.org/changeset/47292>?
Comment 3 Oliver Hunt 2009-08-17 18:02:00 PDT
Committed r47404