Bug 28205 - [Chromium] drop down menu letter selection, skip selections
: [Chromium] drop down menu letter selection, skip selections
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: WebKit Misc.
: 528+ (Nightly build)
: PC Windows XP
: P2 Normal
Assigned To: Nobody
http://www.njtransit.com/sf/sf_servle...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-11 17:54 PDT by Xiaomei Ji
Modified: 2009-08-13 19:53 PDT (History)
3 users (show)

See Also:


Attachments
patch w/ manual test (5.19 KB, patch)
2009-08-11 18:26 PDT, Xiaomei Ji
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Xiaomei Ji 2009-08-11 17:54:49 PDT
steps to reproduce the problem?
1. go to the above website with a dropdown selection menu
2. click the drop down menu to show selections
3. press a letter (such as 'A') to skip to the selection you want
4. it will automatically skip to the 2nd corresponding lettered selection
5. continue press 'A', it selects every other item.

Chromium bug:
http://code.google.com/p/chromium/issues/detail?id=18950
Comment 1 Xiaomei Ji 2009-08-11 18:26:48 PDT
Created attachment 34631 [details]
patch w/ manual test
Comment 2 Eric Seidel 2009-08-12 10:20:25 PDT
Comment on attachment 34631 [details]
patch w/ manual test

OK.
Comment 3 Eric Seidel 2009-08-12 14:09:04 PDT
Comment on attachment 34631 [details]
patch w/ manual test

Rejecting patch 34631 from commit-queue.  This patch will require manual commit.

WebKitTools/Scripts/run-webkit-tests --no-launch-safari --quiet failed with exit code 1
Comment 4 Eric Seidel 2009-08-12 14:17:23 PDT
Comment on attachment 34631 [details]
patch w/ manual test

The failure was:
Testing 11049 test cases.
fast/js/global-constructors.html -> failed

Which should be unrelated.  I expect the bots just went red and I didn't notice.
Comment 5 Xiaomei Ji 2009-08-12 14:41:50 PDT
(In reply to comment #4)
> (From update of attachment 34631 [details])
> The failure was:
> Testing 11049 test cases.
> fast/js/global-constructors.html -> failed
> 
> Which should be unrelated.  I expect the bots just went red and I didn't
> notice.

you probably right. There is no such failure in my local run with my change.
Comment 6 Eric Seidel 2009-08-12 14:49:26 PDT
Comment on attachment 34631 [details]
patch w/ manual test

Clearing flags on attachment: 34631

Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebCore/ChangeLog
	A	WebCore/manual-tests/keyboard_select_elements_with_same_beginning.html
	M	WebCore/platform/chromium/PopupMenuChromium.cpp
Committed r47150
	M	WebCore/ChangeLog
	M	WebCore/platform/chromium/PopupMenuChromium.cpp
	A	WebCore/manual-tests/keyboard_select_elements_with_same_beginning.html
r47150 = bc763ed3dfd04ac8690009160a8baa8af4d3053e (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
http://trac.webkit.org/changeset/47150
Comment 7 Eric Seidel 2009-08-12 14:49:30 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Hironori Bono 2009-08-13 19:53:40 PDT
*** Bug 28254 has been marked as a duplicate of this bug. ***