Bug 27854 - crash at WebCore::AXObjectCache::notificationPostTimerFired
Summary: crash at WebCore::AXObjectCache::notificationPostTimerFired
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: chris fleizach
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-30 13:46 PDT by chris fleizach
Modified: 2009-07-30 14:51 PDT (History)
0 users

See Also:


Attachments
patch (2.52 KB, patch)
2009-07-30 14:02 PDT, chris fleizach
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description chris fleizach 2009-07-30 13:46:20 PDT
accessibility related crash. the accessibility object is not outliving the timer notification
Comment 1 chris fleizach 2009-07-30 14:02:12 PDT
Created attachment 33834 [details]
patch
Comment 2 chris fleizach 2009-07-30 14:02:39 PDT
here the crash bt

          53 com.apple.AppKit:  NSAccessibilityPostNotification + 28
            53 com.apple.WebCore:  WebCore::AXObjectCache::notificationPostTimerFired + 94
              53 com.apple.WebCore:  WebCore::Timer<WebCore::AXObjectCache>::fired + 72
                53 com.apple.WebCore:  WebCore::ThreadTimers::fireTimers + 78
                  53 com.apple.WebCore:  WebCore::ThreadTimers::sharedTimerFiredInternal + 106
                    53 com.apple.WebCore:  WebCore::ThreadTimers::sharedTimerFired + 22
                      53 com.apple.WebCore:  WebCore::timerFired + 63
Comment 3 chris fleizach 2009-07-30 14:03:14 PDT
i was not able to reproduce this crash, but the backtrace is pretty clear. accessibility objects are being released before the timer can fire and the notification can be posted
Comment 4 chris fleizach 2009-07-30 14:03:44 PDT
so there's no layout test, since i could not repro
Comment 5 chris fleizach 2009-07-30 14:51:08 PDT
http://trac.webkit.org/changeset/46604