Bug 27667 - REGRESSION (r46298): Exception after clicking on Bookmarks button in the Bookmarks Bar
Summary: REGRESSION (r46298): Exception after clicking on Bookmarks button in the Book...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P1 Major
Assignee: Darin Adler
URL:
Keywords: Regression
: 27678 27692 27710 27728 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-24 14:51 PDT by sdudla_uk
Modified: 2021-09-28 13:29 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdudla_uk 2009-07-24 14:51:16 PDT
After installing the latest nightly build I lost the ability to open the Bookmarks folder in the Bookmarks Bar. I was able to open the Favourite sites folder but some of my bookmarks are used too infrequently to be included there. Instead of opening when the Bookmarks icon is clicked Safari tries to go back to a previous page but does so very slowly.
Comment 1 Mark Rowe (bdash) 2009-07-24 17:04:01 PDT
This broke with <http://trac.webkit.org/changeset/46298>.  The console shows:

-[WebHTMLView pageTitle]: unrecognized selector sent to instance 0x1017a04a0
*** WebKit discarded an uncaught exception in the webView:decidePolicyForMIMEType:request:frame:decisionListener: delegate: <NSInvalidArgumentException> -[WebHTMLView pageTitle]: unrecognized selector sent to instance 0x1017a04a0
Comment 2 Darin Adler 2009-07-24 17:56:24 PDT
http://trac.webkit.org/changeset/46384
Comment 3 Mark Rowe (bdash) 2009-07-25 12:16:03 PDT
*** Bug 27678 has been marked as a duplicate of this bug. ***
Comment 4 Mark Rowe (bdash) 2009-07-27 13:23:49 PDT
*** Bug 27728 has been marked as a duplicate of this bug. ***
Comment 5 Mark Rowe (bdash) 2009-07-27 13:23:59 PDT
*** Bug 27710 has been marked as a duplicate of this bug. ***
Comment 6 Mark Rowe (bdash) 2009-07-27 13:24:11 PDT
*** Bug 27692 has been marked as a duplicate of this bug. ***