Bug 27505 - Use or large box-shadow radius causes lag and performance issues
: Use or large box-shadow radius causes lag and performance issues
Status: RESOLVED DUPLICATE of bug 22102
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: All Mac OS X 10.5
: P1 Major
Assigned To: Nobody
Depends on:
  Show dependency treegraph
Reported: 2009-07-21 09:28 PDT by Josh Bryant
Modified: 2010-08-21 13:29 PDT (History)
5 users (show)

See Also:

Test Case (38 bytes, text/plain)
2009-07-21 09:36 PDT, Josh Bryant
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Bryant 2009-07-21 09:28:50 PDT
When using a large radius on a box-shadow, on both Mac and PC, Safari 4 causes a massive CPU takeover in which just having it on screen can use up to 40% CPU and trying to do anything (hover over a link, type text in a text field, etc...) will spike the CPU to 100%.

It also makes the entire page pretty much unusable due to the lag.

I've done a test case here: http://tinycrumb.org/boxshadowcpu.html
Comment 1 Josh Bryant 2009-07-21 09:36:52 PDT
Created attachment 33183 [details]
Test Case
Comment 2 Bruce Cowan 2010-05-01 17:10:53 PDT
I can confirm this. http://identi.ca/ is very difficult to use, and scrolls very slowly. Offending item in CSS is "-webkit-box-shadow: rgba(194, 194, 194, 0.296875) 5px 7px 7px;".
Comment 3 Simon Fraser (smfr) 2010-07-27 11:19:05 PDT
Probably dup.
Comment 4 Paul Irish 2010-08-21 12:58:34 PDT
probably a dupe of issue 22102
Comment 5 Simon Fraser (smfr) 2010-08-21 13:29:01 PDT

*** This bug has been marked as a duplicate of bug 22102 ***