Bug 27153 - Add delegate methods about focus and blur and state change
Summary: Add delegate methods about focus and blur and state change
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Greg Bolsinga
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-10 11:33 PDT by Greg Bolsinga
Modified: 2009-08-12 09:56 PDT (History)
2 users (show)

See Also:


Attachments
This patch implements the needed changes (7.65 KB, patch)
2009-07-10 12:04 PDT, Greg Bolsinga
no flags Details | Formatted Diff | Diff
Remove the FrameView diff; it wasn't supposed to be there. (7.08 KB, patch)
2009-07-10 12:08 PDT, Greg Bolsinga
koivisto: review+
Details | Formatted Diff | Diff
fixes up delegate method names (3.20 KB, patch)
2009-08-10 13:12 PDT, Greg Bolsinga
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Bolsinga 2009-07-10 11:33:21 PDT
Some platforms need to be informed when focus and blur events occur. They may display chrome UI when these events occur.
Comment 1 Greg Bolsinga 2009-07-10 12:04:19 PDT
Created attachment 32569 [details]
This patch implements the needed changes
Comment 2 Greg Bolsinga 2009-07-10 12:08:39 PDT
Created attachment 32570 [details]
Remove the FrameView diff; it wasn't supposed to be there.
Comment 3 Antti Koivisto 2009-07-10 13:12:17 PDT
Comment on attachment 32570 [details]
Remove the FrameView diff; it wasn't supposed to be there.

r=me
Comment 4 Greg Bolsinga 2009-07-10 13:32:58 PDT
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebCore/ChangeLog
	M	WebCore/html/HTMLFormControlElement.cpp
	M	WebCore/html/HTMLFormControlElement.h
	M	WebCore/loader/EmptyClients.h
	M	WebCore/page/ChromeClient.h
	M	WebKit/mac/ChangeLog
	M	WebKit/mac/WebCoreSupport/WebChromeClient.h
	M	WebKit/mac/WebCoreSupport/WebChromeClient.mm
	M	WebKit/mac/WebView/WebUIDelegatePrivate.h
Committed r45723
Comment 5 Adele Peterson 2009-07-10 13:36:39 PDT
The naming is a little weird. formDidFocus gets called when a form control was focused...and formDidFocus doesn't actually give any info about a particular form.
Comment 6 David Kilzer (:ddkilzer) 2009-07-10 15:18:58 PDT
Non-Mac build fix:  <http://trac.webkit.org/changeset/45729>
Comment 7 Greg Bolsinga 2009-07-10 17:19:21 PDT
I named it this way following the style of:

virtual void formStateDidChange(const Node*)

What do you suggest?
Comment 8 Greg Bolsinga 2009-08-10 13:05:15 PDT
I see what you mean now. I'll attach a patch to clean up these delegate method names.
Comment 9 Greg Bolsinga 2009-08-10 13:12:41 PDT
Created attachment 34503 [details]
fixes up delegate method names

This is a new patch.
Comment 10 Eric Seidel (no email) 2009-08-11 22:44:01 PDT
Comment on attachment 34503 [details]
fixes up delegate method names

Looks fine.
Comment 11 Greg Bolsinga 2009-08-12 09:56:13 PDT
Thanks!

Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	WebKit/mac/ChangeLog
	M	WebKit/mac/WebCoreSupport/WebChromeClient.mm
	M	WebKit/mac/WebView/WebUIDelegatePrivate.h
Committed r47119