Bug 27078 - <object> elements have a white background
Summary: <object> elements have a white background
Status: RESOLVED DUPLICATE of bug 10687
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 27190 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-08 05:42 PDT by vincent.quint
Modified: 2010-01-25 10:22 PST (History)
5 users (show)

See Also:


Attachments
A test case. You should not see any white area in this page. (620 bytes, text/html)
2009-07-08 06:12 PDT, vincent.quint
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description vincent.quint 2009-07-08 05:42:54 PDT
I am embedding an SVG drawing in a XHTML page using an <object> element. The XHTML page has a blue background and the SVG has no background (its background is transparent). The SVG drawing should then be displayed with the same blue background as the XHTML page. Instead of that it has a white background.
If I put the same SVG code inline in the XHTML page, without the <object> element, everything is fine.
I guess the issue comes from the <object> element.
Comment 1 vincent.quint 2009-07-08 06:12:39 PDT
Created attachment 32450 [details]
A test case. You should not see any white area in this page.
Comment 2 Mark Rowe (bdash) 2009-07-12 10:48:52 PDT
*** Bug 27190 has been marked as a duplicate of this bug. ***
Comment 3 Cameron McCormack 2009-07-15 17:41:00 PDT

*** This bug has been marked as a duplicate of bug 10687 ***
Comment 4 Matthieu Chaton 2009-10-19 03:58:24 PDT
In fact it's not a duplicate of bug 10687

I have a xhtml page, with the svg included this way :
<object id='module_txt_1' style='z-index:10; position: absolute; top:0px;
left:0px; background:red;' type='image/svg+xml'
data='../accueil/module.svg'></object>

you can see the result here : http://v1.xeolia.com/webkit_pb.png

The problem doesn't occur when the object's type is not svg