Bug 26960 - [Gtk] caret offset not updated when selecting text
Summary: [Gtk] caret offset not updated when selecting text
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P3 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks: 25531
  Show dependency treegraph
 
Reported: 2009-07-03 21:40 PDT by Joanmarie Diggs (irc: joanie)
Modified: 2009-07-27 17:53 PDT (History)
4 users (show)

See Also:


Attachments
caretoffset.patch (2.32 KB, patch)
2009-07-04 09:03 PDT, Xan Lopez
jmalonzo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joanmarie Diggs (irc: joanie) 2009-07-03 21:40:24 PDT
Steps to reproduce:

1. Launch Epiphany and Accerciser.

2. In Epiphany, position the caret within some text.

3. In Accerciser's tree of accessibles on the left, highlight the accessible text object which corresponds to the object chosen in step 2.

4. In Accerciser's iPython Console, type:

     acc.queryText().caretOffset

5. In Epiphany, press Shift + Right Arrow two times to select two characters to the right

6. In Accerciser's iPython Console, type:

     acc.queryText().caretOffset

Expected results: The offset returned in step 6 would reflect the new location of the caret (the step 4 offset + 2).

Actual results: The offset returned in step 6 is the same as the step 4 offset.

(Xan, I believe that the fix for this bug, combined with your fixes for bug 26814 and bug 26815, should cause the presentation of selected text by ATs like Orca to JustWork(tm) -- which will be awesome. Sorry for not catching this one the other day!!)
Comment 1 Xan Lopez 2009-07-04 09:03:50 PDT
Created attachment 32255 [details]
caretoffset.patch

Well, it was basically the same bug than the other cases, but in a different place.
Comment 2 Jan Alonzo 2009-07-04 14:20:35 PDT
Comment on attachment 32255 [details]
caretoffset.patch

This looks fine. r=me.

We need to think of a way to test these changes in the future while we don't have an AXController in DRT yet. Maybe more unit tests.
Comment 3 Joanmarie Diggs (irc: joanie) 2009-07-06 08:18:11 PDT
This patch seems to be working nicely. Thanks!!
Comment 4 Jan Alonzo 2009-07-07 03:51:30 PDT
(In reply to comment #3)
> This patch seems to be working nicely. Thanks!!

Thanks for verifying Joanmarie. Fix landed in r45549.
Comment 5 Joanmarie Diggs (irc: joanie) 2009-07-27 17:53:04 PDT
(re)Verifying. :-) Thanks.