Bug 26534 - window.location.hash doesn't update until change tab
Summary: window.location.hash doesn't update until change tab
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: History (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Critical
Assignee: Nobody
URL: http://extjs.com/deploy/dev/examples/...
Keywords: NeedsReduction
: 26535 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-19 02:49 PDT by Robert Dougan
Modified: 2010-10-08 14:08 PDT (History)
3 users (show)

See Also:


Attachments
Testcase for the bug (631 bytes, text/html)
2009-07-01 02:13 PDT, Robert Dougan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Dougan 2009-06-19 02:49:28 PDT
This occurs in the latest Nightly and also Latest release of Safari.

You can view the error here:
http://extjs.com/deploy/dev/examples/history/history.html

Or simple open web inspector and type:
window.location.hash = "#hello"

It will not appear straight away, you must open a new tab/switch to an existing tab then activate the previous tab again, then it appears.
Comment 1 Mark Rowe (bdash) 2009-06-19 13:59:16 PDT
*** Bug 26535 has been marked as a duplicate of this bug. ***
Comment 2 Mark Rowe (bdash) 2009-06-28 16:22:30 PDT
Given the size of the JavaScript behind that page, it's hard to see where the problem is.  We could do with a reduced test case that contained only the code relevant to demonstrating the problem.
Comment 3 Robert Dougan 2009-07-01 02:13:04 PDT
Created attachment 32121 [details]
Testcase for the bug
Comment 4 Robert Dougan 2009-07-07 09:17:18 PDT
I don't get it, this is a critical bug- LOADS of modern/web 2.0 websites use the hash for history management. Would this not need to be fixed ASAP?
Comment 5 Jack Godwin 2009-11-24 11:26:34 PST
Is there any known workaround for this bug?
Comment 6 Alexey Proskuryakov 2009-11-24 13:20:50 PST
I cannot reproduce this with Safari 4.0.4 on Mac OS X 10.5.8. I open the attached test case, click "Add hash", and "#hello" is immediately appended.

I also tried doing 'window.location.hash = "#hello"' in Web Inspector - that works, too.

Do you have any "Safari enhancers" installed? It's possible that this is not a WebKit or Safari bug at all.
Comment 7 Mihai Parparita 2010-10-08 14:08:37 PDT
I'm also not able to reproduce this (either with the attached testcase or with http://extjs.com/deploy/dev/examples/history/history.html). Please re-open if you observe this happening with either Safari 5.0 or a WebKit nightly.