Bug 26531 - Timezone calculation incorrect in Venezuela.
: Timezone calculation incorrect in Venezuela.
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Gavin Barraclough
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 21:56 PDT by Gavin Barraclough
Modified: 2009-06-18 22:07 PDT (History)
0 users

See Also:


Attachments
The patch (2.14 KB, patch)
2009-06-18 21:58 PDT, Gavin Barraclough
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Barraclough 2009-06-18 21:56:53 PDT
The problem is that we're calculating the timezone relative to 01/01/2000, but the VET timezone changed from -4 hours to -4:30 hours on 12/09/2007.  According to the spec, section 15.9.1.9 states "the time since the beginning of the year", presumably meaning the *current* year.  Change the calculation to be based on whatever the current year is, rather than a canned date.
Comment 1 Gavin Barraclough 2009-06-18 21:58:48 PDT
Created attachment 31532 [details]
The patch
Comment 2 Geoffrey Garen 2009-06-18 22:02:48 PDT
Comment on attachment 31532 [details]
The patch

r=me assuming all JSC tests pass
Comment 3 Gavin Barraclough 2009-06-18 22:07:24 PDT
Sending        JavaScriptCore/ChangeLog
Sending        JavaScriptCore/wtf/DateMath.cpp
Transmitting file data ..
Committed revision 44842.