Bug 26530 - Support transitions and animations of backgrounds, including gradients
Summary: Support transitions and animations of backgrounds, including gradients
Status: RESOLVED DUPLICATE of bug 21725
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-18 20:24 PDT by Simon Fraser (smfr)
Modified: 2009-12-16 11:36 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-06-18 20:24:54 PDT
WebKit should support transitions of CSS gradients. As a first pass, we should animate between gradients with the same type, and the same number of color stops.

In future, we could synthesize color stops to be able to animate between gradients with different numbers of stops.

I guess we could interpolate between radial and linear by increasing the radius towards infinity?
Comment 1 Simon Fraser (smfr) 2009-06-18 20:30:43 PDT
Hrm, this is harder than I thought. We actually need to animate background-image; -webkit-gradient is just a type of image.
Comment 2 Simon Fraser (smfr) 2009-06-18 21:19:05 PDT
It's even harder:
1. Ideally we need to handle transitions via FillLayers, so we deal with multiple backgrounds.
2. When we do this, we should make it so that we can cross-fade background images.
3. The CSS gradient info is not held in the RenderStyle structures. The StyleImage for a gradient is a StyleGeneratedImage, which points back to a CSSImageGeneratorValue, from which a Gradient is created on the fly for painting.
Comment 3 Simon Fraser (smfr) 2009-12-16 11:36:00 PST

*** This bug has been marked as a duplicate of bug 21725 ***