Bug 26503 - Regression: Page no longer renders table with data
Summary: Regression: Page no longer renders table with data
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.expertflyer.com/air/fareIn...
Keywords:
Depends on: 26587
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 18:53 PDT by Douglas Yung
Modified: 2009-06-23 01:33 PDT (History)
1 user (show)

See Also:


Attachments
Repro page (114.07 KB, text/html)
2009-06-17 18:55 PDT, Douglas Yung
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Douglas Yung 2009-06-17 18:53:58 PDT
I use a subscription service (www.expertflyer.com), and recently with nightly build #44552 a page that previously rendered correctly in nightly build #44524 no longer renders. I can see the data is in the page by examining the page's source code, but it is not being rendered.
Comment 1 Douglas Yung 2009-06-17 18:55:19 PDT
Created attachment 31482 [details]
Repro page

Added html page that should be able to repro the issue without subscribing to the service.
Comment 2 Alexey Proskuryakov 2009-06-21 00:03:18 PDT
This happens because we now have an incomplete implementation of JSON object, which confuses the web site.
Comment 3 Oliver Hunt 2009-06-22 21:34:36 PDT
Fixed now that 26587 is completed.

Please verify in current nightly :D
Comment 4 Douglas Yung 2009-06-23 01:33:12 PDT
Verified the table is now correctly rendering in build r44932.