Bug 26450 - Rename values of enum RedirectOriginCheck to make them clearer.
: Rename values of enum RedirectOriginCheck to make them clearer.
Product: WebKit
Classification: Unclassified
Component: WebCore Misc.
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Jian Li
Depends on:
  Show dependency treegraph
Reported: 2009-06-16 11:39 PDT by Jian Li
Modified: 2009-06-16 14:01 PDT (History)
0 users

See Also:

Proposed Patch (5.67 KB, patch)
2009-06-16 11:54 PDT, Jian Li
levin: review-
Details | Formatted Diff | Diff
Proposed Patch (25.29 KB, patch)
2009-06-16 13:11 PDT, Jian Li
levin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jian Li 2009-06-16 11:39:48 PDT
Rename enum value RequireSameRedirectOrigin to DenyCrossOriginRedirect, and AllowDifferentRedirectOrigin to AllowCrossOriginRedirect.
Comment 1 Jian Li 2009-06-16 11:54:55 PDT
Created attachment 31361 [details]
Proposed Patch
Comment 2 David Levin 2009-06-16 12:33:28 PDT
Comment on attachment 31361 [details]
Proposed Patch

How about CrossOriginRedirectPolicy as the enum name as it seems more consistent with the naming of the enums values?
Comment 3 Jian Li 2009-06-16 13:11:56 PDT
Created attachment 31366 [details]
Proposed Patch
Comment 4 David Levin 2009-06-16 13:19:52 PDT
Comment on attachment 31366 [details]
Proposed Patch

Comment 5 Jian Li 2009-06-16 14:01:52 PDT
Committed as http://trac.webkit.org/changeset/44737