Bug 26430 - With accelerated compositing, elements can jump when gaining backing
Summary: With accelerated compositing, elements can jump when gaining backing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2009-06-15 22:12 PDT by Simon Fraser (smfr)
Modified: 2009-07-14 15:46 PDT (History)
1 user (show)

See Also:


Attachments
Testcase (994 bytes, text/html)
2009-06-15 22:12 PDT, Simon Fraser (smfr)
no flags Details
Patch, testcase, changelog (24.35 KB, patch)
2009-06-22 15:39 PDT, Simon Fraser (smfr)
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-06-15 22:12:30 PDT
When RenderLayers become compositing because of a 3d transform or a transition, they sometimes jump around incorrectly. This happens when some other element with backing projects above/to the left of the document.
Comment 1 Simon Fraser (smfr) 2009-06-15 22:12:39 PDT
Created attachment 31332 [details]
Testcase
Comment 2 Simon Fraser (smfr) 2009-06-15 23:14:54 PDT
The bug is that in rebuildCompositingLayerTree() the answer to calculateCompositedBounds() changes as later siblings become composited.
Comment 3 Simon Fraser (smfr) 2009-06-16 09:52:02 PDT
<rdar://problem/6944442>
Comment 4 Simon Fraser (smfr) 2009-06-22 15:39:06 PDT
Created attachment 31680 [details]
Patch, testcase, changelog
Comment 5 Dave Hyatt 2009-06-22 15:40:43 PDT
Comment on attachment 31680 [details]
Patch, testcase, changelog

r=me
Comment 6 Simon Fraser (smfr) 2009-06-22 15:45:41 PDT
http://trac.webkit.org/changeset/44961
Comment 7 Simon Fraser (smfr) 2009-07-14 15:46:55 PDT
*** Bug 27272 has been marked as a duplicate of this bug. ***