Bug 26358 - Implement HTML 5's HTMLElement.classList property
: Implement HTML 5's HTMLElement.classList property
Status: RESOLVED DUPLICATE of bug 20709
Product: WebKit
Classification: Unclassified
Component: HTML DOM
: 528+ (Nightly build)
: Macintosh All
: P2 Enhancement
Assigned To: Adam Roben (:aroben)
: InRadar
Depends on:
  Show dependency treegraph
Reported: 2009-06-12 15:35 PDT by Adam Roben (:aroben)
Modified: 2009-06-18 02:02 PDT (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2009-06-12 15:35:36 PDT
HTML 5 adds a "classList" property to HTMLElement. The classList property makes it easy to add, remove, and toggle classes on an Element. We should implement support for this in WebKit!

See <http://www.whatwg.org/specs/web-apps/current-work/multipage/dom.html#dom-classlist> for a little bit of information about classList, and <http://www.whatwg.org/specs/web-apps/current-work/multipage/infrastructure.html#domtokenlist-0> for information about the DOMTokenList interface, which is the interface the object returned by classList implements.
Comment 1 Adam Roben (:aroben) 2009-06-15 08:57:11 PDT
Comment 2 Adam Roben (:aroben) 2009-06-15 08:58:44 PDT
I sent an email to the WHATWG mailing list asking about the case-sensitivity of element.classList methods: <http://lists.whatwg.org/pipermail/whatwg-whatwg.org/2009-June/020425.html>.
Comment 3 Adam Roben (:aroben) 2009-06-16 06:45:45 PDT

*** This bug has been marked as a duplicate of 20709 ***