Bug 26325 - REGRESSION: JIRA Filter menu is broken with r44591
Summary: REGRESSION: JIRA Filter menu is broken with r44591
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P1 Major
Assignee: Nobody
URL: http://jira.atlassian.com/secure/Dash...
Keywords: Regression
Depends on: 26587
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 10:47 PDT by Dimitris Apostolou
Modified: 2009-08-18 12:18 PDT (History)
2 users (show)

See Also:


Attachments
Screenshot (304.42 KB, image/png)
2009-06-11 10:49 PDT, Dimitris Apostolou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitris Apostolou 2009-06-11 10:47:31 PDT
Safari Version 4.0 (5530.17, r44591)

Steps:
1. Go to http://jira.atlassian.com/secure/Dashboard.jspa
2. Click on "Filters" drop down menu on the top right.

What happened:
Error message below.

Unable to interpret data sent back from the JIRA server.
Perhaps the user's session has timed out?
Perhaps the user does not have JIRA 'use' permission?

200 - OK
TypeError: Result of expression 'JSON.parse' [undefined] is not a function

Expected result:
Filter drod down menu is expanded.

Notes:
Regression from previous WebKit build.
Comment 1 Dimitris Apostolou 2009-06-11 10:49:02 PDT
Created attachment 31166 [details]
Screenshot
Comment 2 Alexey Proskuryakov 2009-06-15 12:26:22 PDT
I'd guess that this is caused by JSON.stringify being already implemented, but JSON.parse not yet.
Comment 3 Dimitris Apostolou 2009-06-22 01:00:40 PDT
Verified with r44929

Closing.
Comment 4 Dimitris Apostolou 2009-08-18 12:18:55 PDT
Closing.