Bug 26320 - Some minor code cleanup needed in Chromium/Skia
: Some minor code cleanup needed in Chromium/Skia
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Platform
: 528+ (Nightly build)
: PC Windows XP
: P4 Normal
Assigned To: Adam Barth
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 08:00 PDT by Stephen White
Modified: 2009-06-13 21:54 PDT (History)
1 user (show)

See Also:


Attachments
Janitorial pass (4.85 KB, patch)
2009-06-11 08:05 PDT, Stephen White
no flags Details | Formatted Diff | Diff
Removed a FIXME (4.92 KB, patch)
2009-06-11 08:11 PDT, Stephen White
dglazkov: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen White 2009-06-11 08:00:16 PDT
Should remove #ifndef SK_USE_OLD_255_TO_256 around old Skia API calls.
Comment 1 Stephen White 2009-06-11 08:02:22 PDT
*** Bug 26321 has been marked as a duplicate of this bug. ***
Comment 2 Stephen White 2009-06-11 08:05:30 PDT
Created attachment 31163 [details]
Janitorial pass
Comment 3 Stephen White 2009-06-11 08:11:01 PDT
Created attachment 31164 [details]
Removed a FIXME
Comment 4 Adam Barth 2009-06-13 21:33:03 PDT
Will land.
Comment 5 Adam Barth 2009-06-13 21:54:04 PDT
Sending        WebCore/ChangeLog
Sending        WebCore/platform/graphics/chromium/FontCacheLinux.cpp
Sending        WebCore/platform/graphics/chromium/TransparencyWin.h
Sending        WebCore/platform/graphics/skia/PathSkia.cpp
Sending        WebCore/platform/graphics/skia/SkiaUtils.cpp
Transmitting file data .....
Committed revision 44667.