Bug 26228 - Media controls might be clickable even if hidden.
Summary: Media controls might be clickable even if hidden.
Status: RESOLVED DUPLICATE of bug 26659
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-05 14:40 PDT by Pierre d'Herbemont
Modified: 2009-06-25 11:00 PDT (History)
1 user (show)

See Also:


Attachments
patch v1. (1.29 KB, patch)
2009-06-05 14:41 PDT, Pierre d'Herbemont
no flags Details | Formatted Diff | Diff
patch v2. (1.34 KB, patch)
2009-06-05 14:48 PDT, Pierre d'Herbemont
eric: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre d'Herbemont 2009-06-05 14:40:38 PDT
Some media controls are hidden with { display: none; }. We should make sure hit test does not return true in that case..
Comment 1 Pierre d'Herbemont 2009-06-05 14:41:00 PDT
Created attachment 31012 [details]
patch v1.
Comment 2 Pierre d'Herbemont 2009-06-05 14:48:14 PDT
Created attachment 31013 [details]
patch v2.

(bugzilla id added in the changelog).
Comment 3 Eric Seidel (no email) 2009-06-06 01:21:07 PDT
Comment on attachment 31013 [details]
patch v2.

It should be possible to make a test case for this using eventSender.

r- for lack of test case.
Comment 4 Simon Fraser (smfr) 2009-06-25 11:00:38 PDT
This will be fixed by bug 26659.

*** This bug has been marked as a duplicate of 26659 ***