Bug 26163 - Canceling, then restarting transition picks up where it left off
: Canceling, then restarting transition picks up where it left off
Status: RESOLVED FIXED
: WebKit
CSS
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2009-06-03 10:59 PST by
Modified: 2009-06-18 21:38 PST (History)


Attachments
Test case (1.92 KB, text/html)
2009-06-03 11:00 PST, Chris Marrin
no flags Details
Patch with test (18.27 KB, patch)
2009-06-15 11:40 PST, Chris Marrin
simon.fraser: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-03 10:59:52 PST
Open the attached testcase in TOT and hover over the big box. The transitions start as they should. When you unhover, they jump back as they should. But if you quickly hover again, the transitions pick up where they left off. It's as though they're still running.
------- Comment #1 From 2009-06-03 11:00:24 PST -------
Created an attachment (id=30914) [details]
Test case
------- Comment #2 From 2009-06-03 11:25:53 PST -------
Ah, happens on TOT, so not hardware.
------- Comment #3 From 2009-06-15 11:40:51 PST -------
Created an attachment (id=31301) [details]
Patch with test
------- Comment #4 From 2009-06-15 15:22:32 PST -------
Sending        LayoutTests/ChangeLog
Adding         LayoutTests/transitions/cancel-transition-expected.txt
Adding         LayoutTests/transitions/cancel-transition.html
Sending        WebCore/ChangeLog
Sending        WebCore/page/animation/CompositeAnimation.cpp
Sending        WebCore/page/animation/ImplicitAnimation.cpp
Sending        WebCore/page/animation/ImplicitAnimation.h
Transmitting file data .......
Committed revision 44696.
------- Comment #5 From 2009-06-18 21:38:36 PST -------
*** Bug 26165 has been marked as a duplicate of this bug. ***