Bug 26094 - Unreproducible crashes below JSC::Interpreter::execute
Summary: Unreproducible crashes below JSC::Interpreter::execute
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-29 18:32 PDT by John Moe
Modified: 2009-07-12 14:36 PDT (History)
2 users (show)

See Also:


Attachments
Crash r43436 (2.50 KB, text/plain)
2009-05-29 18:33 PDT, John Moe
no flags Details
crash r44111 (2.50 KB, text/plain)
2009-05-29 18:33 PDT, John Moe
no flags Details
Crash r44282 (2.67 KB, text/plain)
2009-06-07 17:18 PDT, John Moe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Moe 2009-05-29 18:32:07 PDT
Not sure how to reproduce, but it has happened twice so I am attaching the stack traces.
Comment 1 John Moe 2009-05-29 18:33:28 PDT
Created attachment 30799 [details]
Crash r43436
Comment 2 John Moe 2009-05-29 18:33:51 PDT
Created attachment 30800 [details]
crash r44111
Comment 3 John Moe 2009-06-07 15:25:05 PDT
And once more today.  Am I the only person seeing this?
Comment 4 Gavin Barraclough 2009-06-07 16:24:27 PDT
We had a bug making crashes with this backtrace common pre r43885, which certainly addressed the majority of cases of this problem.  The crash on r44111 is interesting since it is the first instance I've seen of a crash here since that fix went in.

If you continue to see this crash repeat, then any steps to reproduce (any websites that might be candidates for triggering the crash, behavior – the last problem tended to manifest when you returned to your machine having left it unused for a while & under high memory load, etc) would be hugely appreciated.

cheers,
G.
Comment 5 John Moe 2009-06-07 17:18:16 PDT
Created attachment 31035 [details]
Crash r44282

I believe I was on fark.com and had just pressed command-L.  Not reproducible.
Comment 6 John Moe 2009-07-12 14:36:55 PDT
This has stopped happening to me.  I got a new computer, a new Safari was released, and new WebKit versions were released.  The world may never know the cause.