Bug 259364 - REGRESSION (iOS 17 Beta): The camera preview is with a wrong resolution for a short time when the iOS User enables/disables the camera
Summary: REGRESSION (iOS 17 Beta): The camera preview is with a wrong resolution for a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 17
Hardware: iPhone / iPad Other
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
: 261330 262618 266686 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-07-20 13:46 PDT by Madara Freimane
Modified: 2023-12-20 12:26 PST (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Madara Freimane 2023-07-20 13:46:28 PDT
Summary:
The camera preview is with a wrong resolution for a short time when the iOS User enables/disables the camera OR joins a WebRTC call with video ON

Tested devices:
The bug is reproducible on:
- iPhone 12 Pro (iOS 17.0 Public Beta) with Safari (V17.0)
- iPhone 11 Pro Max (iOS 17 Public Beta, build: 21A5277j) and Safari
- iPhone 11 Pro Max (iOS 17 Public Beta, build: 21A5277j) and Google Chrome (V115.0.5790.130)

The bug is not reproducible on:
- iPhone 13 (iOS 16.5.1) and Safari
- iPhone 14 (iOS 16.5.1) and Safari
- iPhone XS (iOS 16.4.1) and Safari

Scenario:
Precondition:
Safari or Google Chrome browser opened on iOS 17 device

Steps:
Use case1:
1. iOS User joins WEbRTC call with video ON
2. iOS User observes local video preview while being in connecting state

Use case2:
1. iOS User disables and enables camera back 
2. iOS User observes the camera preview while changing the status of the camera

Actual result:
The camera preview is with a wrong resolution for a short time when the iOS User enables/disables the camera OR joins a call with video ON

Expected result:
The camera preview appears immediately with the correct resolution when the iOS User enables/disables the camera in a WebRTC call

Reproducibility:
90%


Additional information:
-Sysdiagnostics file added:
https://drive.google.com/file/d/1Z3IxXUjNdt4zWOubg4H52WrDGBXH3CGZ/view?usp=sharing
(bug reproduced at 23:25, EET, 20.07.2023.)
Comment 1 Radar WebKit Bug Importer 2023-07-20 14:45:54 PDT
<rdar://problem/112621697>
Comment 2 Madara Freimane 2023-08-17 02:30:47 PDT
Bug is still reproducible. 
3rd use case:
iOS User rotates device screen, and observes the camera preview

Tested devices and browsers:
- iPhone 11 Pro (iOS 17 Developer Beta 6, build: 21A5312c) and Safari
- iPhone 14 Pro (iOS 17 Public Beta 4, build: 21A5312c) and Safari
- iPhone 13 (iOS 17 Public Beta 4, build: 21A5312c) and Safari

Added a new sysdiagnostics file (bug reproduced at 12:13, EET, 17.08.2023.):
https://drive.google.com/file/d/1_I6m42MmuqeB6iwS4Mglf8XpIvm5fbPz/view?usp=sharing
Comment 3 chris.pettet 2023-09-06 16:44:08 PDT
Still seeing this on iOS 17.0 (21A5326a), Safari. The getUserMedia sample linked below is an easy way to reproduce the bug.

getUserMedia sample: https://webrtc.github.io/samples/src/content/getusermedia/gum/

getUserMedia source: https://github.com/webrtc/samples/tree/gh-pages/src/content/getusermedia/gum
Comment 4 youenn fablet 2023-09-22 01:21:05 PDT
Pull request: https://github.com/WebKit/WebKit/pull/18069
Comment 5 rychouwei 2023-10-12 06:10:55 PDT
Hi, I have same issue here, I would like to know is this issue being fixed? And which iOS version will launch this fixed.
Comment 6 youenn fablet 2023-10-12 07:35:23 PDT
This is being investigated.
Comment 7 rychouwei 2023-10-12 20:10:36 PDT
Thank you for your response, is there any workaround here?
Comment 8 youenn fablet 2023-10-13 05:52:55 PDT
*** Bug 261330 has been marked as a duplicate of this bug. ***
Comment 9 youenn fablet 2023-11-10 02:50:41 PST
*** Bug 262618 has been marked as a duplicate of this bug. ***
Comment 10 EWS 2023-11-10 10:29:55 PST
Committed 270548@main (57afaa96431b): <https://commits.webkit.org/270548@main>

Reviewed commits have been landed. Closing PR #18069 and removing active labels.
Comment 11 youenn fablet 2023-12-20 12:26:57 PST
*** Bug 266686 has been marked as a duplicate of this bug. ***