Bug 25901 - [Gtk] Use ATK_ROLE_SECTION for divTag and ATK_ROLE_LABEL for labelTag
Summary: [Gtk] Use ATK_ROLE_SECTION for divTag and ATK_ROLE_LABEL for labelTag
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P3 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks: 25531
  Show dependency treegraph
 
Reported: 2009-05-20 17:03 PDT by Joanmarie Diggs (irc: joanie)
Modified: 2009-10-18 09:23 PDT (History)
5 users (show)

See Also:


Attachments
aforementioned test case (179 bytes, text/html)
2009-05-20 17:04 PDT, Joanmarie Diggs (irc: joanie)
no flags Details
proposed patch - take 1 (2.82 KB, patch)
2009-10-17 21:42 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joanmarie Diggs (irc: joanie) 2009-05-20 17:03:40 PDT
Steps to reproduce:

1. Open the (to be) attached test case.

2. Use Accerciser to explore the accessible hierarchy

Expected results: The text enclosed in <div></div> would be contained in an accessible object of ROLE_SECTION.

Actual results: The text enclosed in <div></div> is contained in an accessible object of ROLE_PANEL.

As for paragraphs contained in <div></div>, the expected hierarchy would include both roles, thus:

- ROLE_SECTION
  - ROLE_PARAGRAPH
    - ROLE_TEXT
Comment 1 Joanmarie Diggs (irc: joanie) 2009-05-20 17:04:46 PDT
Created attachment 30516 [details]
aforementioned test case
Comment 2 Joanmarie Diggs (irc: joanie) 2009-10-17 21:20:21 PDT
Now that I'm actually looking at these things from the other side.... :-)

Bug 25530 is really two different bugs (and possibly three):

1. The accessible role being used with labels is wrong

2. The LABEL_FOR/LABELLED_BY relationship pair is missing (because, among other things, it seems accessible relationships haven't been implemented yet)

3. The accessible name of the AtkObject which is LABELLED_BY the label should be taken from the name of the label. And I'm starting to suspect that ain't going to happen magically on its own.

So.... I've re-purposed this bug to deal with issue 1 (roles). 25530 can deal with the other two issues.

Also, regarding this bit:

> As for paragraphs contained in <div></div>, the expected hierarchy would
> include both roles, thus:
> 
> - ROLE_SECTION
>   - ROLE_PARAGRAPH
>     - ROLE_TEXT

I suggested it because that's what Gecko does. I'm now starting to think doing that might be rather pointless, not to mention introduce a bunch of unneeded additional accessibles into the mix which might negatively impact performance. Therefore, I'm withdrawing this part for now. If, upon further consideration, I want it after all, I'll file a new bug for it.
Comment 3 Joanmarie Diggs (irc: joanie) 2009-10-17 21:42:56 PDT
Created attachment 41370 [details]
proposed patch - take 1

Tested with both the test case for this bug and for the test case for bug 25530.
Comment 4 Holger Freyther 2009-10-18 08:46:16 PDT
Seems fine but I'm waiting for Xan to comment.
Comment 5 Xan Lopez 2009-10-18 08:57:34 PDT
Comment on attachment 41370 [details]
proposed patch - take 1

Yep, looks good!
Comment 6 WebKit Commit Bot 2009-10-18 09:23:23 PDT
Comment on attachment 41370 [details]
proposed patch - take 1

Clearing flags on attachment: 41370

Committed r49751: <http://trac.webkit.org/changeset/49751>
Comment 7 WebKit Commit Bot 2009-10-18 09:23:27 PDT
All reviewed patches have been landed.  Closing bug.