Bug 25839 - XSLT document() function does not work (via Javascript XSLTProcessor)
Summary: XSLT document() function does not work (via Javascript XSLTProcessor)
Status: RESOLVED DUPLICATE of bug 10313
Alias: None
Product: WebKit
Classification: Unclassified
Component: XML (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-17 02:30 PDT by bitsteller
Modified: 2009-05-17 11:51 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bitsteller 2009-05-17 02:30:42 PDT
When I run a XSLT Transformation with the JavaScript XSLT API in Webkit (XSLTProcessor.transformToDocument() function), the document() function in XSLT which should fetch another document, simply does nothing.

This is a testing file:
http://dl.getdropbox.com/u/771983/webkit-test/doc.html

It transforms "doc.xml" with the XSLT stylesheet "ref.xsl" (which tries to read some data from "another-file.xml" via document()).

In Firefox/Gecko, Opera and even IE it runs as it should.

---
By the way: When the Transformation process is started via <?xml-stylesheet?> Processing Instruction the document() function works with Webkit.

Testing file:
http://dl.getdropbox.com/u/771983/webkit-test/doc.xml

---

Tested with Midori/Webkit from https://launchpad.net/~webkit-team/+archive/ppa.
Also confirmed on Windows running Google Chrome and Safari.
Comment 1 Alexey Proskuryakov 2009-05-17 11:51:29 PDT
This is pretty much the same as bug 10313 - since the underlying issue is identical, I think that there is no need to track this separately.

*** This bug has been marked as a duplicate of 10313 ***