Bug 25568 - Add ASSERT(useTransforms) to mapLocalToContainer and fix patterns on transformed text
Summary: Add ASSERT(useTransforms) to mapLocalToContainer and fix patterns on transfor...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 25532
  Show dependency treegraph
 
Reported: 2009-05-05 07:45 PDT by Eric Seidel (no email)
Modified: 2009-05-05 18:20 PDT (History)
1 user (show)

See Also:


Attachments
Add back ASSERT(useTransforms) (11.33 KB, patch)
2009-05-05 07:46 PDT, Eric Seidel (no email)
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-05-05 07:45:04 PDT
Add ASSERT(useTransforms) to mapLocalToContainer and fix patterns on transformed text

This is the last patch attached to https://bugs.webkit.org/show_bug.cgi?id=25532 which got landed, and then rolled out, and now is ready for landing again.
Comment 1 Eric Seidel (no email) 2009-05-05 07:46:36 PDT
Created attachment 30018 [details]
Add back ASSERT(useTransforms)

 7 files changed, 130 insertions(+), 19 deletions(-)
Comment 2 Eric Seidel (no email) 2009-05-05 07:47:35 PDT
I'll add the expected results when I land.  Since the important part is the pixel tests, they're of little use to the reviewer and just make the patch larger.
Comment 3 Simon Fraser (smfr) 2009-05-05 08:43:46 PDT
Comment on attachment 30018 [details]
Add back ASSERT(useTransforms)

r=me

Would prefer we replace the isPaintingText bool with an enum to make the code more readable at the call site (even though it wasn't added in this patch).
Comment 4 Eric Seidel (no email) 2009-05-05 08:57:02 PDT
(In reply to comment #3)
> (From update of attachment 30018 [details] [review])
> r=me
> 
> Would prefer we replace the isPaintingText bool with an enum to make the code
> more readable at the call site (even though it wasn't added in this patch).

Thank you.  I think the enum change is for another patch though.  We're almost to the point where we don't even need it for this function!

Comment 5 Eric Seidel (no email) 2009-05-05 18:20:54 PDT
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	M	LayoutTests/ChangeLog
	M	LayoutTests/platform/mac/svg/transforms/animated-path-inside-transformed-html-expected.checksum
	M	LayoutTests/platform/mac/svg/transforms/animated-path-inside-transformed-html-expected.png
	A	LayoutTests/platform/mac/svg/transforms/text-with-pattern-inside-transformed-html-expected.checksum
	A	LayoutTests/platform/mac/svg/transforms/text-with-pattern-inside-transformed-html-expected.png
	A	LayoutTests/platform/mac/svg/transforms/text-with-pattern-inside-transformed-html-expected.txt
	A	LayoutTests/platform/mac/svg/transforms/text-with-pattern-with-svg-transform-expected.checksum
	A	LayoutTests/platform/mac/svg/transforms/text-with-pattern-with-svg-transform-expected.png
	A	LayoutTests/platform/mac/svg/transforms/text-with-pattern-with-svg-transform-expected.txt
	A	LayoutTests/svg/transforms/text-with-pattern-inside-transformed-html.xhtml
	A	LayoutTests/svg/transforms/text-with-pattern-with-svg-transform.svg
	M	WebCore/ChangeLog
	M	WebCore/rendering/RenderSVGRoot.cpp
	M	WebCore/rendering/SVGRenderSupport.cpp
	M	WebCore/svg/graphics/SVGPaintServerPattern.cpp
Committed r43269