Bug 25409 - [GTK] incorrectly fallsback on cancellation
Summary: [GTK] incorrectly fallsback on cancellation
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2009-04-26 10:05 PDT by Gustavo Noronha (kov)
Modified: 2009-04-27 07:54 PDT (History)
1 user (show)

See Also:


Attachments
Fix fallback and cancellation handling (2.00 KB, patch)
2009-04-26 10:28 PDT, Gustavo Noronha (kov)
no flags Details | Formatted Diff | Diff
Do not fallback on cancellation and load interruption caused by policy change. (1.56 KB, patch)
2009-04-26 17:28 PDT, Gustavo Noronha (kov)
xan.lopez: review+
Details | Formatted Diff | Diff
Check if we should use the fallback content in didFailLoad. (1.66 KB, patch)
2009-04-26 17:28 PDT, Gustavo Noronha (kov)
xan.lopez: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha (kov) 2009-04-26 10:05:36 PDT
On some sites, there are some frames appearing with the fallback content when they shouldn't. The error message that is presented is that the load was cancelled. Also, our shouldFallBack implementation seems to miss some cancellation cases, which makes some tests fail.
Comment 1 Gustavo Noronha (kov) 2009-04-26 10:28:24 PDT
Created attachment 29803 [details]
Fix fallback and cancellation handling

 WebKit/gtk/ChangeLog                               |   16 ++++++++++++++++
 WebKit/gtk/WebCoreSupport/FrameLoaderClientGtk.cpp |    8 +++++++-
 2 files changed, 23 insertions(+), 1 deletions(-)
Comment 2 Gustavo Noronha (kov) 2009-04-26 17:28:09 PDT
Created attachment 29809 [details]
Do not fallback on cancellation and load interruption caused by policy change.

 WebKit/gtk/ChangeLog                               |   14 ++++++++++++++
 WebKit/gtk/WebCoreSupport/FrameLoaderClientGtk.cpp |    3 +--
 2 files changed, 15 insertions(+), 2 deletions(-)
Comment 3 Gustavo Noronha (kov) 2009-04-26 17:28:13 PDT
Created attachment 29810 [details]
Check if we should use the fallback content in didFailLoad.

 WebKit/gtk/ChangeLog                               |   14 ++++++++++++++
 WebKit/gtk/WebCoreSupport/FrameLoaderClientGtk.cpp |    6 ++++++
 2 files changed, 20 insertions(+), 0 deletions(-)
Comment 4 Xan Lopez 2009-04-26 22:40:48 PDT
Comment on attachment 29809 [details]
Do not fallback on cancellation and load interruption caused by policy change.

Looks good.
Comment 5 Xan Lopez 2009-04-26 22:44:07 PDT
Comment on attachment 29810 [details]
Check if we should use the fallback content in didFailLoad.

Perhaps you can add the same comment to the signal emission than Jan did, to be consistent. r=me otherwise.
Comment 6 Gustavo Noronha (kov) 2009-04-27 07:54:55 PDT
Landed as r42888, r42889 with Xan's comment addressed.