Bug 25125 - REGRESSION (r42334): Scrollbars disappear on GMail after resizing window
: REGRESSION (r42334): Scrollbars disappear on GMail after resizing window
Status: RESOLVED FIXED
: WebKit
Frames
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P1 Normal
Assigned To:
:
: InRadar, Regression
:
:
  Show dependency treegraph
 
Reported: 2009-04-09 16:19 PST by
Modified: 2009-04-21 21:44 PST (History)


Attachments
Patch (11.69 KB, patch)
2009-04-13 13:25 PST, Dave Hyatt
sam: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-04-09 16:19:34 PST
In gmail, if you resize the window, the vertical scrollbar goes away.
------- Comment #1 From 2009-04-09 16:21:32 PST -------
<rdar://problem/6776898>
------- Comment #2 From 2009-04-09 18:34:36 PST -------
Happen to know which revision caused this?
------- Comment #3 From 2009-04-10 13:23:01 PST -------
I believe this was caused by r42334. <http://trac.webkit.org/changeset/42334>
------- Comment #4 From 2009-04-13 13:25:44 PST -------
Created an attachment (id=29435) [details]
Patch
------- Comment #5 From 2009-04-13 13:52:42 PST -------
(From update of attachment 29435 [details])
Yeah for scrollbars!  r=me
------- Comment #6 From 2009-04-13 14:34:35 PST -------
Fixed in r42464.
------- Comment #7 From 2009-04-15 09:39:49 PST -------
*** Bug 25203 has been marked as a duplicate of this bug. ***
------- Comment #8 From 2009-04-15 09:46:18 PST -------
This seems to be the kind of thing that a layout test would have caught before the initial regression.

It would benefit everyone if there was a layout test written to prevent this from happening again and verify that this patch actually fixes the reported problem.
------- Comment #9 From 2009-04-21 21:44:49 PST -------
I'm still having this problem occasionally in r42662.  I haven't found a consistent way to reproduce it, but it most commonly happens when I open a new gmail conversation which has multiple unread components and thus extends off the bottom of the screen.