CompositeAnimationPrivate, in the CSS animation code, really doesn't provide any useful layering, and should be removed.
Created attachment 29359 [details]
Comment on attachment 29359 [details]
> + m_compAnim->animationControllerPriv()->removeFromStyleAvailableWaitList(this);
> + m_compAnim->animationControllerPriv()->removeFromStartTimeResponseWaitList(this);
The function name animationControllerPriv() is both long and abbreviated. And I find it ugly. Can you give it a shorter name without abbreviations? Or I guess you could use our standard name for such things, impl(), which I also find ugly.
Aside from this new function that needs a better name, r=me
There are quite a few things here that aren't using standard WebKit style, using "get" for example for simple getters, whereas we use nouns for getters and "get" only for getters that use out arguments. And this design with the private object that you get to explicitly is also pretty awkward.
I'd like to do the rename of getAnimatedStyle() (to computeAnimtedStyle() perhaps) in another patch, because that rename should extend outside of AnimationController.
I renamed animationControllerPriv() to just animationController(). I know that the normal term is just animation(), but that's very confusing in this context.