Bug 24961 - [GTK] Require GTK+ >= 2.10
Summary: [GTK] Require GTK+ >= 2.10
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks: 22898
  Show dependency treegraph
 
Reported: 2009-03-31 11:49 PDT by Gustavo Noronha (kov)
Modified: 2009-04-03 06:04 PDT (History)
0 users

See Also:


Attachments
require gtk+ >= 2.10 (14.99 KB, patch)
2009-03-31 11:49 PDT, Gustavo Noronha (kov)
zecke: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha (kov) 2009-03-31 11:49:16 PDT
As discussed in https://bugs.webkit.org/show_bug.cgi?id=22898, I believe it's about time we stop trying to support GTK+ versions bellow 2.10. The amount of functionality we lose, and the fact that we already depend on a very new libsoup version make it very difficult to argue for going extra miles to provide support for GTK+ version 2.8.
Comment 1 Gustavo Noronha (kov) 2009-03-31 11:49:44 PDT
Created attachment 29128 [details]
require gtk+ >= 2.10


        Reviewed by NOBODY (OOPS!).

        Require GTK+ >= 2.10; 2.8 is already very old, and some very
        useful APIs are only available since 2.10.

        * configure.ac:

WebCore/

2009-03-31  Gustavo Noronha Silva  <gustavo.noronha@collabora.co.uk>

        Reviewed by NOBODY (OOPS!).

        Remove pre-processor checks for GTK+ >= 2.10, since we now require
        at least that version.

        * platform/graphics/gtk/FontPlatformDataGtk.cpp:
        (WebCore::FontPlatformData::FontPlatformData):
        * platform/gtk/ContextMenuItemGtk.cpp:
        (WebCore::gtkStockIDFromContextMenuAction):
        * platform/gtk/KeyEventGtk.cpp:
        (WebCore::PlatformKeyboardEvent::PlatformKeyboardEvent):
        * platform/gtk/LocalizedStringsGtk.cpp:
        (WebCore::contextMenuItemTagSelectAll):
        * platform/gtk/MouseEventGtk.cpp:
        (WebCore::PlatformMouseEvent::PlatformMouseEvent):
        * platform/gtk/PasteboardGtk.cpp:
        (WebCore::Pasteboard::writeSelection):
        (WebCore::Pasteboard::documentFragment):
        * platform/gtk/WheelEventGtk.cpp:
        (WebCore::PlatformWheelEvent::PlatformWheelEvent):

WebKit/gtk

2009-03-31  Gustavo Noronha Silva  <gustavo.noronha@collabora.co.uk>

        Reviewed by NOBODY (OOPS!).

        Remove pre-processor checks for GTK+ >= 2.10, since we now require
        at least that version.

        * WebCoreSupport/EditorClientGtk.cpp:
        (WebKit::clipboard_clear_contents_cb):
        (WebKit::EditorClient::respondToChangedSelection):
        * webkit/webkitwebframe.cpp:
        * webkit/webkitwebview.cpp:
---
 ChangeLog                                          |    9 +++++++
 WebCore/ChangeLog                                  |   23 ++++++++++++++++++++
 .../platform/graphics/gtk/FontPlatformDataGtk.cpp  |    6 +---
 WebCore/platform/gtk/ContextMenuItemGtk.cpp        |    2 -
 WebCore/platform/gtk/KeyEventGtk.cpp               |    8 -------
 WebCore/platform/gtk/LocalizedStringsGtk.cpp       |    4 ---
 WebCore/platform/gtk/MouseEventGtk.cpp             |    8 -------
 WebCore/platform/gtk/PasteboardGtk.cpp             |    8 -------
 WebCore/platform/gtk/WheelEventGtk.cpp             |    8 -------
 WebKit/gtk/ChangeLog                               |   13 +++++++++++
 WebKit/gtk/WebCoreSupport/EditorClientGtk.cpp      |    4 ---
 WebKit/gtk/webkit/webkitwebframe.cpp               |   11 ---------
 WebKit/gtk/webkit/webkitwebview.cpp                |   10 --------
 configure.ac                                       |    2 +-
 14 files changed, 48 insertions(+), 68 deletions(-)
Comment 2 Gustavo Noronha (kov) 2009-03-31 11:51:20 PDT
Comment on attachment 29128 [details]
require gtk+ >= 2.10

I am asking zecke to review this, specifically, as he is also the one who will need to make sure the bot has the appropriate version.
Comment 3 Holger Freyther 2009-04-02 23:14:41 PDT
Comment on attachment 29128 [details]
require gtk+ >= 2.10

The buildbot has a jhbuild setup so Gtk+ and Glib should be fairly recent.
Comment 4 Gustavo Noronha (kov) 2009-04-03 06:04:34 PDT
Landed as r42199.