Bug 24957 - REGRESSION (r41547): Google calendar widget no longer shows upcoming events
Summary: REGRESSION (r41547): Google calendar widget no longer shows upcoming events
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: XML (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords: GoogleBug, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2009-03-31 08:36 PDT by Ismail Donmez
Modified: 2009-04-09 22:18 PDT (History)
4 users (show)

See Also:


Attachments
proposed fix (4.82 KB, patch)
2009-04-01 07:41 PDT, Alexey Proskuryakov
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ismail Donmez 2009-03-31 08:36:57 PDT
How to reproduce;

- Add some upcoming events in your Google calendar
- Enable Google calendar widget in GMail Lab settings

Expected behaviour:

Calendar widget shows upcoming events.

Current behaviour:

Upcoming event list is empty.


Used to work in older WebKit revisions (Safari 4 Beta works fine), so this is a regression.
Comment 1 Cameron Zwarich (cpst) 2009-03-31 09:04:04 PDT
This regressed between the r41545 and r41698 nightlies. I'll try to find the exact point of regression by bisecting local builds.
Comment 2 Cameron Zwarich (cpst) 2009-03-31 11:07:53 PDT
This regressed in r41547:

http://trac.webkit.org/changeset/41547

This is probably not our bug, so I'll put it in the Evangelism component.
Comment 3 Cameron Zwarich (cpst) 2009-03-31 11:10:27 PDT
You can see the console spam from attempts to set headers that are no longer allowed by the XHR spec.
Comment 4 Cameron Zwarich (cpst) 2009-03-31 11:58:45 PDT
Marking this P2 because it's an evangelism bug.
Comment 6 Alexey Proskuryakov 2009-03-31 14:28:14 PDT
I am not aware of any real reason to block the Authorization header, other than following the spec. Anne, are you?

Undoing this part of the change may be a better solution than evangelizing Google.
Comment 7 Eric Seidel (no email) 2009-03-31 14:55:08 PDT
I've filed a Google bug on the issue:  http://b/1749893
Comment 8 Jon@Chromium 2009-03-31 16:16:33 PDT
Also reported to the public Chromium bug tracker at http://code.google.com/p/chromium/issues/detail?id=8935
Comment 9 Alexey Proskuryakov 2009-04-01 07:41:13 PDT
Created attachment 29160 [details]
proposed fix

So far, there seems to be no resistance to the idea of removing Authorization from the list of forbidden headers on public-webapps mailing list.
Comment 10 Maciej Stachowiak 2009-04-06 21:48:29 PDT
Fix looks good to me.
Comment 11 Maciej Stachowiak 2009-04-07 11:01:46 PDT
Comment on attachment 29160 [details]
proposed fix

r=me
Comment 12 Alexey Proskuryakov 2009-04-08 00:04:10 PDT
Committed <http://trac.webkit.org/changeset/42314>.

Please verify that this actually fixes the calendar widget - I don't use it, so I didn't attempt to.
Comment 13 Ismail Donmez 2009-04-09 22:18:26 PDT
Verified.