Bug 24956 - CSS Transition perf bad in combination with CSS gradients on MacBook Air / lower end graphics chips
Summary: CSS Transition perf bad in combination with CSS gradients on MacBook Air / lo...
Status: RESOLVED DUPLICATE of bug 24130
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://farukat.es/bugs/webkit-css-gra...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-30 19:14 PDT by Faruk Ates
Modified: 2009-04-23 23:03 PDT (History)
2 users (show)

See Also:


Attachments
Reduced test case (1.07 KB, text/html)
2009-03-30 19:47 PDT, Faruk Ates
no flags Details
Test case showing that giving the HTML element a background color fixes the issue (1.14 KB, text/html)
2009-03-30 20:02 PDT, Faruk Ates
no flags Details
Third test case, using a gradient on the HTML element (1.20 KB, text/html)
2009-03-30 20:03 PDT, Faruk Ates
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Faruk Ates 2009-03-30 19:14:01 PDT
CSS Gradients can cause a significant slowdown in rendering performance when using CSS Transitions, but this is predominantly noticeable on the MacBook Air and other computers with integrated graphics. 

Moving an element around that sits on top of a gradient causes serious frame rate drops (as measured with Quartz Debug). On a solid background it transitions smoothly.
Comment 1 Faruk Ates 2009-03-30 19:47:26 PDT
Created attachment 29108 [details]
Reduced test case
Comment 2 Faruk Ates 2009-03-30 20:02:36 PDT
Created attachment 29109 [details]
Test case showing that giving the HTML element a background color fixes the issue

Added a second test case that sets a solid color on the html element, which makes performance snappy again. Using a gradient (third test case, soon to be attached) as opposed to a solid color, makes it go slow again.
Comment 3 Faruk Ates 2009-03-30 20:03:02 PDT
Created attachment 29110 [details]
Third test case, using a gradient on the HTML element
Comment 4 Simon Fraser (smfr) 2009-04-23 23:03:08 PDT
Same cause as bug 24130.

*** This bug has been marked as a duplicate of 24130 ***