Bug 24759 - Exceptions in removeStyleClass and enclosingNodeOrSelfWithNodeName
Summary: Exceptions in removeStyleClass and enclosingNodeOrSelfWithNodeName
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yury Semikhatsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-23 09:02 PDT by Yury Semikhatsky
Modified: 2009-03-24 10:09 PDT (History)
1 user (show)

See Also:


Attachments
a patch definging missing methods in the iframe (1.89 KB, patch)
2009-03-23 10:40 PDT, Yury Semikhatsky
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2009-03-23 09:02:42 PDT
WebCore/inspector/front-end/SourceFrame.js adds method removeStyleClass to 
Element.prototype in content iframe(http://trac.webkit.org/browser/trunk/WebCore/inspector/front-end/SourceFrame.js#L227). Though the method calls removeMatchingStyleClasses which is not defined for Element.

The same problem with Node.prototype.enclosingNodeOrSelfWithNodeName and Node.prototype.enclosingNodeOrSelfWithNodeNameInArray. 

The problem is repeatable with Chrome and for some reason is not repeatable with Safari.
Comment 1 Yury Semikhatsky 2009-03-23 10:40:24 PDT
Created attachment 28857 [details]
a patch definging missing methods in the iframe
Comment 2 Darin Adler 2009-03-23 11:31:16 PDT
Comment on attachment 28857 [details]
a patch definging missing methods in the iframe

r=me
Comment 3 Dimitri Glazkov (Google) 2009-03-23 13:22:00 PDT
I'll land.
Comment 4 Dimitri Glazkov (Google) 2009-03-24 10:09:29 PDT
Landed as http://trac.webkit.org/changeset/41940.