Bug 24749 - Hangs when loading
Summary: Hangs when loading
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Cameron Zwarich (cpst)
URL: http://www.weekendavisen.dk/artikler/...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2009-03-22 12:31 PDT by Morten Norby Larsen
Modified: 2009-09-11 09:28 PDT (History)
2 users (show)

See Also:


Attachments
A shark time profile (436.97 KB, application/octet-stream)
2009-03-22 12:33 PDT, Morten Norby Larsen
no flags Details
Page source saved from Firefox (3.27 MB, application/zip)
2009-03-22 22:58 PDT, Morten Norby Larsen
no flags Details
Partial reduction (171.59 KB, text/html)
2009-03-23 00:38 PDT, Cameron Zwarich (cpst)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Norby Larsen 2009-03-22 12:31:39 PDT
With the progress bar at about 40%, the page hangs and teh cursor turns into a spinning beachball.
Comment 1 Morten Norby Larsen 2009-03-22 12:33:54 PDT
Created attachment 28837 [details]
A shark time profile
Comment 2 Morten Norby Larsen 2009-03-22 12:53:12 PDT
Build: Version 4 Public Beta (5528.16, r41894)
Comment 3 Mark Rowe (bdash) 2009-03-22 21:18:35 PDT
It'd be worth attaching a version of the page in question in case it changes, perhaps by saving it from Firefox.
Comment 4 Morten Norby Larsen 2009-03-22 22:58:26 PDT
Created attachment 28848 [details]
Page source saved from Firefox

Oddly, the problem doesn't seem to manifest itself when read from the source files on disk.
Comment 5 Cameron Zwarich (cpst) 2009-03-22 23:04:13 PDT
The problem doesn't manifest because none of the style files or JS files load. Adding a <base> element makes it reproduce just fine. I'm going to assign this to myself and try to find a reduction. The problem is caused by layout triggered by getting the offsetWidth property of an element. There is a long section of <div> elements with identical styles. I suspect there is some quadratic (or worse) behaviour being triggered by the style.
Comment 6 Cameron Zwarich (cpst) 2009-03-23 00:38:06 PDT
Created attachment 28849 [details]
Partial reduction

Still has way too much JQuery.
Comment 7 Morten Norby Larsen 2009-09-11 09:28:34 PDT
I just tried the last test case, and in WebKit.app Version 4.0.3 (6531.9, r48276) it does not reproduce any more.

Suggest closing this bug.