Bug 24715 - LEAK hangs after short time of inaction
Summary: LEAK hangs after short time of inaction
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://nightly.webkit.org/start/trunk...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-20 03:05 PDT by jay
Modified: 2009-03-21 01:19 PDT (History)
1 user (show)

See Also:


Attachments
Texte d'échantillon (36.24 KB, text/plain)
2009-03-20 04:36 PDT, jay
no flags Details
hang before force quit (35.97 KB, text/plain)
2009-03-20 12:41 PDT, jay
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2009-03-20 03:05:10 PDT
open safari nightly

wait patiently

laptop fan comes on

safari has crashed

how to open nightly on blank page?
Comment 1 Mark Rowe (bdash) 2009-03-20 03:11:05 PDT
Please provide a crash log: <http://webkit.org/quality/crashlogs.html>.  There's not much we can do without one.
Comment 2 jay 2009-03-20 03:11:43 PDT
no crash report, but closing does not work so one has to force close.
from the report dialogue

Date/Time:      2009-03-20 10:08:43 +0000
OS Version:     10.5.6 (Build 9G55)
Architecture:   ppc
Report Version: 4

Command:        Safari
Path:           /Applications/Safari.app/Contents/MacOS/Safari
Version:        3.2.1 (5525.27.1)
Build Version:  1
Project Name:   WebBrowser
Source Version: 55252701
Parent:         launchd [66]

PID:            2239
Event:          hang
Time:           5.08s
Steps:          18
Comment 3 jay 2009-03-20 03:15:07 PDT
#mark, this bug has been around for quite a while.

initially thought it was svg related

have had to stop using safari nightly, because it hangs so readily.

tried the leak report, but need further instructions,
http://webkit.org/quality/leakhunting.html

Set the MallocStackLogging environment variable to YES (in bash, export MallocStackLogging=YES, in tcsh, setenv MallocStackLogging YES).
Run Safari using run-safari.
Browse around a little.
From the command line, run leaks Safari.

precisely what should be done in terminal
ie

Last login: Thu Mar 19 12:51:14 on console
Jay:~ jonathanchetwynd$ export MallocStackLogging=YES
Jay:~ jonathanchetwynd$ run-safari
-bash: run-safari: command not found
Jay:~ jonathanchetwynd$ ./run-safari
-bash: ./run-safari: No such file or directory
Jay:~ jonathanchetwynd$ 

tx
Comment 4 Mark Rowe (bdash) 2009-03-20 03:26:11 PDT
Perhaps you would attach the entire hang report to the bug.  The header alone isn't useful either.
Comment 5 jay 2009-03-20 03:34:36 PDT
#mark

it would help if you left instructions on how to find the hang report

afaict the header was all that was displayed in the force quit dialogue.
Comment 6 Mark Rowe (bdash) 2009-03-20 03:42:05 PDT
Simple alternative if you can't find it: Run Activity Monitor.  When the process starts to hang, select it in the process list, click Sample Process on the toolbar.  Copy the results into a text file, save, and attach.
Comment 7 jay 2009-03-20 04:36:38 PDT
Created attachment 28783 [details]
Texte d'échantillon
Comment 8 Mark Rowe (bdash) 2009-03-20 12:06:42 PDT
This sample does not appear to be taken when the browser is unresponsive.
Comment 9 jay 2009-03-20 12:23:00 PDT
iirc I took the sample after waiting for the fan to come on and having raised the hang dialogue using force quit.
I'll attach another asap

if this is still not as required I will need additional instructions on what to do...


Comment 10 jay 2009-03-20 12:41:04 PDT
Created attachment 28795 [details]
hang before force quit
Comment 11 Mark Rowe (bdash) 2009-03-20 16:37:30 PDT
Again, this shows the main thread as idle.  I don't even understand what you think the problem is here.  Since you're clearly the only one seeing it, I would suggest removing any input managers and Safari extensions.
Comment 12 jay 2009-03-21 01:19:36 PDT
mark,

wfm is a not for helpful solution, as I am stuck with broken application.

please could you give me additional instructions on for instance where the hang file might be?

as far as i know I am using neither input handlers not extensions.

is there a uri for instructions to clear the current safari-webkit and reinstalling clean?