Bug 24678 - transitions tests some what flakey on Chromium
Summary: transitions tests some what flakey on Chromium
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Scott Violet
URL:
Keywords:
: 24568 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-18 13:34 PDT by Scott Violet
Modified: 2009-03-19 09:35 PDT (History)
2 users (show)

See Also:


Attachments
Fix for 24678 (1.53 KB, patch)
2009-03-18 13:39 PDT, Scott Violet
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Violet 2009-03-18 13:34:03 PDT
Occassionally the tests in the transitions directory fail on the chromium bot. They occasionally fail with the message:

CONSOLE MESSAGE: line 124: Uncaught Error: NOT_FOUND_ERR: DOM Exception 8

I believe this is from transitions/transition-end-event-helpers.js. Line 124 is:

    document.body.removeChild(document.getElementById('container'));

If we end up trying to process the results twice, then the second time through fails because the element 'container' has been removed.
Comment 1 Scott Violet 2009-03-18 13:39:04 PDT
Created attachment 28731 [details]
Fix for 24678

Modifies test to only process results once.
Comment 2 Scott Violet 2009-03-18 14:11:22 PDT
*** Bug 24568 has been marked as a duplicate of this bug. ***
Comment 3 Dimitri Glazkov (Google) 2009-03-19 09:35:37 PDT
Landed as http://trac.webkit.org/changeset/41837.