Bug 24665 - Hit testing assertion failure at Google Maps API example
: Hit testing assertion failure at Google Maps API example
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Simon Fraser (smfr)
http://code.google.com/apis/maps/docu...
: NeedsReduction
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 22:24 PDT by Cameron Zwarich (cpst)
Modified: 2009-03-22 12:50 PDT (History)
2 users (show)

See Also:


Attachments
Patch, changelog (2.13 KB, patch)
2009-03-22 12:07 PDT, Simon Fraser (smfr)
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Cameron Zwarich (cpst) 2009-03-17 22:24:48 PDT
Hovering over the speech bubble at <http://code.google.com/apis/maps/documentation/examples/map-infowindow.html> causes an assertion failure in hit testing code.

ASSERTION FAILED: !result.innerNode()
(/Users/Cameron/WebKit/WebCore/rendering/RenderLayer.cpp:2407 bool WebCore::RenderLayer::hitTestContents(const WebCore::HitTestRequest&, WebCore::HitTestResult&, const WebCore::IntRect&, const WebCore::IntPoint&, WebCore::HitTestFilter) const)
Comment 1 Simon Fraser (smfr) 2009-03-18 09:27:09 PDT
This means that someone returned true from nodeAtPoint but didn't set result.innerNode().
Comment 2 mitz@webkit.org 2009-03-21 20:12:18 PDT
*** Bug 24744 has been marked as a duplicate of this bug. ***
Comment 3 Simon Fraser (smfr) 2009-03-22 12:07:09 PDT
Created attachment 28836 [details]
Patch, changelog
Comment 4 Simon Fraser (smfr) 2009-03-22 12:50:50 PDT
http://trac.webkit.org/changeset/41900