Bug 24572 - XMLHttpRequest.statusText returns always "OK"
Summary: XMLHttpRequest.statusText returns always "OK"
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords: InRadar
: 29304 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-13 04:10 PDT by Alexey Proskuryakov
Modified: 2010-04-09 15:34 PDT (History)
3 users (show)

See Also:


Attachments
proposed fix (18.60 KB, patch)
2010-04-09 15:11 PDT, Alexey Proskuryakov
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2009-03-13 04:10:59 PDT
Cloned from bug 3547.

XMLHttpRequest.statusText returns a hardcoded value of "OK" on Mac, because ResourceResponseMac.mm cannot get the text from the underlying platform object.

<rdar://problem/5439321>
Comment 1 Alexey Proskuryakov 2009-09-18 08:49:51 PDT
*** Bug 29304 has been marked as a duplicate of this bug. ***
Comment 2 Alexey Proskuryakov 2010-04-09 15:11:55 PDT
Created attachment 52995 [details]
proposed fix
Comment 3 Maciej Stachowiak 2010-04-09 15:15:57 PDT
Comment on attachment 52995 [details]
proposed fix

r=me
Comment 4 Alexey Proskuryakov 2010-04-09 15:34:08 PDT
Fixed in <http://trac.webkit.org/changeset/57373>