Bug 24525 - REGRESSION: Inspector window doesn't close when corresponding page window is closed
Summary: REGRESSION: Inspector window doesn't close when corresponding page window is ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Dimitri Glazkov (Google)
URL:
Keywords:
Depends on: 24106
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 15:41 PDT by Dimitri Glazkov (Google)
Modified: 2009-03-12 12:55 PDT (History)
1 user (show)

See Also:


Attachments
Fix for inspector window closing regression, v1. (2.14 KB, patch)
2009-03-12 12:47 PDT, Dimitri Glazkov (Google)
manyoso: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitri Glazkov (Google) 2009-03-11 15:41:27 PDT
Because I recently made InspectorController ref-counted, it won't destruct naturally by itself when Page is destroyed. I will be fixing this shortly.
Comment 1 Dimitri Glazkov (Google) 2009-03-12 12:47:09 PDT
Created attachment 28541 [details]
Fix for inspector window closing regression, v1.

 WebCore/ChangeLog                         |   15 +++++++++++++++
 WebCore/inspector/InspectorController.cpp |   14 ++++++--------
 2 files changed, 21 insertions(+), 8 deletions(-)
Comment 2 Dimitri Glazkov (Google) 2009-03-12 12:55:17 PDT
Landed as http://trac.webkit.org/changeset/41643.