As suggested in dom/Position.h, this patch gets rid of the 'offset()' accessor and renames posOffset to m_offset. I've used m_offset instead of offset to follow the style guide lines, since Position is still a class and not a structure. If the long term plan is still to make it a structure it would be pretty easy to just s/m_offset/offset/ globally when that is achieved.
Created attachment 28437 [details]
Comment on attachment 28437 [details]
Seems fine, r=me
Thanks, landed in r41553.