Bug 24465 - File inputs do not respond to clicks
Summary: File inputs do not respond to clicks
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-09 11:36 PDT by Marcus Bointon
Modified: 2009-03-09 15:15 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Bointon 2009-03-09 11:36:36 PDT
I'm finding that file input controls simply don't accept clicks. When I click one, on any page (including for example the attachments page on this site), nothing happens at all. Nothing is logged to console. They work fine in earlier releases on the same machine. I spotted a report of someone else having the same problem: comment by 'eyelidless' on this page: http://ajaxian.com/archives/input-typefile-multiple-now-in-a-real-browser
I can drag files onto the control.
Comment 1 Adele Peterson 2009-03-09 11:45:45 PDT
I haven't been able to reproduce this.  Do you have the Safari 4 beta installed?
Comment 2 Marcus Bointon 2009-03-09 11:52:19 PDT
Yes.
Comment 3 Mark Rowe (bdash) 2009-03-09 14:11:55 PDT
Do you have any Safari extensions installed?
Comment 4 Marcus Bointon 2009-03-09 15:15:13 PDT
Yes - and this problem was being caused by an old version of SafariStand. Sorry for not thinking of that.