Bug 24448 - SVG file does not pan and has no scroll bars
Summary: SVG file does not pan and has no scroll bars
Status: RESOLVED DUPLICATE of bug 11225
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-07 16:01 PST by phil colbourn
Modified: 2010-02-09 07:53 PST (History)
3 users (show)

See Also:


Attachments
svg file demonstrates difference between firefox and webkit when panning and scrolling (1.83 KB, image/svg+xml)
2009-03-07 16:12 PST, phil colbourn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description phil colbourn 2009-03-07 16:01:42 PST
May be related to scrollbar issue: https://bugs.webkit.org/show_bug.cgi?id=11225

I have an SVG file that is larger than the window size. It does not show scroll bars and neither does it pan - so I can not see the whole graphic.

I can scale the image using <command><->.

For the scroll bar problem it was suggested to try:

svg:not(:root) {overflow: hidden}

I put it in the SVG file like this:

<style>
svg:not(:root) { overflow: hidden}
</style>

but I see not difference: either I don't understand how I should do this or it doesn't work.

Because I know very little, I also tried:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

and

<?xml version="1.0" encoding="UTF-8" standalone="no"?>

The SVG file is output from GraphViz and panning and scrolling with in firefox.
Comment 1 phil colbourn 2009-03-07 16:12:46 PST
Created attachment 28392 [details]
svg file demonstrates difference between firefox and webkit when panning and scrolling
Comment 2 phil colbourn 2009-03-07 21:28:04 PST
I should have written that ...The SVG file is output from GraphViz and panning and scrolling WORK in firefox 3.
Comment 3 Nikolas Zimmermann 2010-02-09 07:53:40 PST

*** This bug has been marked as a duplicate of bug 11225 ***