Bug 24427 - tool tip/alt. text appears when mouse is no longer hovering over link
Summary: tool tip/alt. text appears when mouse is no longer hovering over link
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Daniel Bates
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2009-03-06 10:47 PST by jeremy boudreau
Modified: 2016-03-31 15:38 PDT (History)
4 users (show)

See Also:


Attachments
Shows alt text appearing (9.83 KB, image/png)
2009-05-12 08:39 PDT, jeremy boudreau
no flags Details
activated context menu (34.16 KB, image/png)
2009-05-12 08:41 PDT, jeremy boudreau
no flags Details
text following the cursor (19.11 KB, image/png)
2009-05-12 08:43 PDT, jeremy boudreau
no flags Details
Example (31.88 KB, text/html)
2009-10-25 13:06 PDT, Daniel Bates
no flags Details
Screen capture of example (2.80 MB, video/quicktime)
2009-10-25 13:17 PDT, Daniel Bates
no flags Details
Recreating the issue in Mail.app (8.91 MB, video/quicktime)
2009-10-25 13:57 PDT, jeremy boudreau
no flags Details
recreating the issue in Safari (8.02 MB, video/quicktime)
2009-10-25 13:59 PDT, jeremy boudreau
no flags Details
Manual Test (33.15 KB, patch)
2016-03-27 23:03 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jeremy boudreau 2009-03-06 10:47:43 PST
Select a link to view in a new tab or window.
When returning to the original area and forcing that window to redraw by scrolling will show the alt information of the original link selected to view in a new tab or window.

Has been reproduced with Safari 3, Safari 4 and OS X Mail.
Comment 1 Alexey Proskuryakov 2009-05-12 08:19:12 PDT
I don't understand this bug report. Could you please give more detailed steps to reproduce, possibly with screenshots?
Comment 2 jeremy boudreau 2009-05-12 08:39:58 PDT
Created attachment 30231 [details]
Shows alt text appearing

When hovering over a link with the alt attribute the text appears as a tool tip.
Comment 3 jeremy boudreau 2009-05-12 08:41:02 PDT
Created attachment 30232 [details]
activated context menu

Shows the context menu being activated on the hyperlink. The issue will occur wether an action from the context menu is chosen or the context menu is simply closed.
Comment 4 jeremy boudreau 2009-05-12 08:43:48 PDT
Created attachment 30233 [details]
text following the cursor

The screen shot does not capture the cursor, but it is in the position that the alt text appears. In the image you can see the "Duane" hyperlink is still selected as a result of activating the context menu. 

If the hyperlink is simply highlighted the issue does not occur.

The alt text appears when the mouse becomes stationary on the page as if it's hovering over the link and will continue to appear until the user clicks somewhere else on the page.
Comment 5 jeremy boudreau 2009-05-12 08:46:50 PDT
When a context menu is activated for a hyperlink that has the alt atribute, that hyperlink is then highlighted and stays selected until the user clicks somewhere else on the page.

During the time that the original hyperlink is still selected the alt text will continue to appear by the mouse cursor when it becomes stationary in that window. To stop the alt text from appearing the user must click somewhere on the page to remove the focus from the selected hyper link.

I've attached screen shots as well, but they don't capture the cursor position.

The behavior is consistent across safari and mail leading me to believe it's an issue with webkit. Let me know if you'd like more details.
Comment 6 jeremy boudreau 2009-07-31 13:13:30 PDT
This issue is still present in Safari 4.0.2(5530.19) and Mail 3.6(935/935.3) running Mac OS X 10.5.7 Build 9j61
Comment 7 jeremy boudreau 2009-10-24 13:41:17 PDT
This issue is still occurring with OS X 10.6.1 Build 10B504 and Safari 4.0.3

Webkit version 531.9
Comment 8 Daniel Bates 2009-10-25 13:06:50 PDT
Created attachment 41823 [details]
Example

Example to reproduce issue.
Comment 9 Daniel Bates 2009-10-25 13:17:42 PDT
Created attachment 41824 [details]
Screen capture of example

This is a screen capture of running the example using r50039.
Comment 10 Daniel Bates 2009-10-25 13:20:46 PDT
Jeremy,

Can you confirm that both the example/screen capture of the example match your description/screen shots of this issue?
Comment 11 jeremy boudreau 2009-10-25 13:54:30 PDT
Hey Daniel,

The example and screen capture are both accurate.

Another item to now. In Mail.app it seems that any hyperlink shows the URL as a tool tip. If you activate a context menu on a hyperlink, close the context menu and then scroll up or down in message viewer that tooltip will reappear. 

Additionally, per your example html, the issue can be recreated without selecting anything from the contextual menu. The tool tip will follow the mouse around the page after the contextual menu is activated and the hyperlink remains highlighted.

I've got two screen captures of the behaviour that I'll attach right shortly.
Comment 12 jeremy boudreau 2009-10-25 13:57:24 PDT
Created attachment 41828 [details]
Recreating the issue in Mail.app
Comment 13 jeremy boudreau 2009-10-25 13:59:27 PDT
Created attachment 41829 [details]
recreating the issue in Safari

Recreating the issue in Safari using example.html without opening a new tab
Comment 14 jeremy boudreau 2009-10-25 14:05:31 PDT
(In reply to comment #13)
> Created an attachment (id=41829) [details]
> recreating the issue in Safari
> 
> Recreating the issue in Safari using example.html without opening a new tab

In order to recreate the issue in safari by closing the contextual menu, without selecting open in new tab, you must be able to scroll up or down in the window. This can be seen with the example html posted by Daniel by making the window short enough to have the vertical scroll bar.
Comment 15 Daniel Bates 2009-10-25 14:55:20 PDT
Jeremy,

Thanks you for the videos and seconding the confirmation of this issue.

(In reply to comment #13)
> Created an attachment (id=41829) [details]
> recreating the issue in Safari
> 
> Recreating the issue in Safari using example.html without opening a new tab
Comment 16 jeremy boudreau 2009-10-25 17:20:48 PDT
Further isolation has revealed:

The same issue occurs using images that have no text inside an <a html> tag - example:
<a href="link.to.somewhere" alt="link to somewhere>
<img src="http://webkit.org/images/download.png>
</a>

Additionally the issue only occurs with a right click on a mouse. By control-clicking to generate a contextual menu the issue doesn't occur.

Lastly, if the user has generated the conditions for the issue to occur, they can cancel it by pressing any key on their keyboard. I believe this has the same effect as clicking somewhere on the page to remove the focus on the hyperlink by forcing it to be deselected.
Comment 17 Daniel Bates 2009-11-04 15:26:04 PST
CC'ing Dan Bernstein on this issue since Oliver recommended him.
Comment 18 mitz 2009-11-04 19:57:14 PST
This appears to be a symptom of bug 29819.
Comment 19 mitz 2010-08-24 14:42:44 PDT
<rdar://problem/8045235>
Comment 20 Antonio Gomes 2016-03-27 22:00:36 PDT
(In reply to comment #18)
> This appears to be a symptom of bug 29819.

This does not reproduce on Safari (webkit nightly) as of 2016/Mar/29. Closing as FIXED.

Please reopen if you disagree.
Comment 21 Daniel Bates 2016-03-27 23:02:18 PDT
Re-opening this bug to propose that we land the example page (attachment #41823 [details]) as a manual test. Although a manual test has significantly less value than an automated test by its nature of requiring a human being to run it by hand, there is still some value in adding the example page as a manual test in terms of having such a test and in aiding in the discoverability/historical preservation of this bug report.
Comment 22 Daniel Bates 2016-03-27 23:03:17 PDT
Created attachment 275016 [details]
Manual Test
Comment 23 Antonio Gomes 2016-03-28 05:44:33 PDT
Comment on attachment 275016 [details]
Manual Test

ok, r=me
Comment 24 Daniel Bates 2016-03-31 15:38:16 PDT
Comment on attachment 275016 [details]
Manual Test

Clearing flags on attachment: 275016

Committed r198922: <http://trac.webkit.org/changeset/198922>
Comment 25 Daniel Bates 2016-03-31 15:38:21 PDT
All reviewed patches have been landed.  Closing bug.