Bug 24415 - Some of the javascript doesn't work
Summary: Some of the javascript doesn't work
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.profitcents.com
Keywords:
: 24416 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-05 17:41 PST by Deepak Gupta
Modified: 2014-02-07 12:36 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Deepak Gupta 2009-03-05 17:41:04 PST
I'm facing some issues with Safari and Chrome related to Java Script. My site works fine with all the browsers like IE, FF, Opera, Netscape etc. But many of the java script functions don't work with Chrome and Safari. I believe they both built on 'WebKit' Engine but Is there any solution around this problem? 

example: I have a function that format the date field, so if you enter 020205, it converts it into 02/02/2005 but if doesn't work in chrome or safari. There are many other function like totaling of the numeric text boxes, doesn't work. They all are client side (JavaScript) functions. 

Please look into this matter and let me if there is any alternate solution of this problem.
 
Thanks!!
Comment 1 Mark Rowe (bdash) 2009-03-05 18:49:12 PST
*** Bug 24416 has been marked as a duplicate of this bug. ***
Comment 2 Mark Rowe (bdash) 2009-03-05 18:50:11 PST
Can you please provide specific steps that can be used to reproduce the problem you are seeing?  The page you link to has no obvious place to enter dates, so I can't see where the bug you mention would occur.
Comment 3 Deepak Gupta 2009-03-06 07:37:33 PST
Hey Mark,
Thanks for the prompt response.

I have created a test account to duplicate the problem. Use the following link:
https://www.profitcents.com/USEN/runreport/incomestatement.aspx?GUID=680fbcdf-7f31-468e-a028-4379a4858226

1. In the date column if you enter 020304 it doesn't auto convert into date format.
2. The data field's should only take number but if you enter any alphabet in these column this doesn't show you the javascript warning message, If you do this on any other browser you get warning message.
3. Their is one total column name 'Adjusted Net Profit before Taxes' should calculate the total of the entered values.

All of them working in other browsers other then Chrome/Safari. Please let me know if you any other questions about it.

Thanks,
Deepak
Comment 4 Anthony Ricaud 2009-03-09 18:19:04 PDT
(In reply to comment #3)
> I have created a test account to duplicate the problem. Use the following link:
> https://www.profitcents.com/USEN/runreport/incomestatement.aspx?GUID=680fbcdf-7f31-468e-a028-4379a4858226
This page asks for a username and password.

Have you tried the Web Inspector to help you debug your code ? See http://developer.apple.com/safari/library/documentation/AppleApplications/Conceptual/Safari_Developer_Guide/2SafariDeveloperTools/chapter_2_section_5.html for instructions about how to enable it. You should see some error messages in the console of the web inspector.
Comment 5 Deepak Gupta 2009-03-09 20:55:28 PDT
you can use this link but it'll expire after 4 days.
https://www.profitcents.com/USEN/runreport/incomestatement.aspx?GUID=ffbf38f3-1c60-49d5-a7f9-b2d3ddd325ec

If you access our web application, you can use UserID:webkittest and password:webkittest
select any kind of analysis, then select the existing company and choose new report. once you reach to the incomestatement.apsx, you can see the problem with the java-script that i mention in my query.
Please let me know if you able to duplicate it.

Thanks.
Comment 6 Anthony Ricaud 2009-03-12 17:26:49 PDT
I wasn't able to reproduce your problems. Maybe you have JavaScript disabled. In Safari, please check in the Develop menu that Disable JavaScript isn't on.