Bug 24302 - ASSERTION FAILED: m_node->parentNode() when copy/paste with evil mutation events
Summary: ASSERTION FAILED: m_node->parentNode() when copy/paste with evil mutation events
Status: RESOLVED DUPLICATE of bug 22634
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 22634
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 15:24 PST by Eric Seidel (no email)
Modified: 2009-03-02 16:30 PST (History)
0 users

See Also:


Attachments
ASSERT stack trace (30.13 KB, text/plain)
2009-03-02 15:24 PST, Eric Seidel (no email)
no flags Details
test case (DOES NOT WORK under DumpRenderTree!), works manually though. (903 bytes, text/html)
2009-03-02 15:32 PST, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-03-02 15:24:26 PST
While trying to make a simpler test case for bug 22634, I ran into another crasher :(

ASSERTION FAILED: m_node->parentNode()
(/Users/eseidel/Projects/WebKit/WebCore/editing/RemoveNodeCommand.cpp:39 WebCore::RemoveNodeCommand::RemoveNodeCommand(WTF::PassRefPtr<WebCore::Node>))

Test case coming shortly.
Comment 1 Eric Seidel (no email) 2009-03-02 15:24:59 PST
Created attachment 28198 [details]
ASSERT stack trace
Comment 2 Eric Seidel (no email) 2009-03-02 15:32:27 PST
Created attachment 28199 [details]
test case (DOES NOT WORK under DumpRenderTree!), works manually though.
Comment 3 Eric Seidel (no email) 2009-03-02 16:30:45 PST
The fix attached to bug 22634 seems to fix this ASSERT as well.

*** This bug has been marked as a duplicate of 22634 ***