Bug 24220 - GCGetGlyphIdealMetrics fails and causes random text
Summary: GCGetGlyphIdealMetrics fails and causes random text
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.eliloewen.com
Keywords: InRadar, NeedsReduction, ReviewedForRadar
Depends on:
Blocks:
 
Reported: 2009-02-26 21:45 PST by Eli Loewen
Modified: 2014-08-30 16:27 PDT (History)
5 users (show)

See Also:


Attachments
Console output of GCGetGlyphIdealMetrics errors (26.55 KB, text/plain)
2009-02-27 08:48 PST, Cameron Zwarich (cpst)
no flags Details
Reduction (192 bytes, text/html)
2009-02-27 08:58 PST, Cameron Zwarich (cpst)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eli Loewen 2009-02-26 21:45:27 PST
I just got the nightly of webkit r41242 and tested it in my website and when I did all the text on the site was replaced by random text and characters with a ton of errors  in the logs saying

"2/26/09 9:38:08 PM Safari[728] GCGetGlyphIdealMetrics failed: error 1."

Here is a pic of the page is you want:
http://img9.imageshack.us/img9/1084/picture1glb.png
Comment 1 Mark Rowe (bdash) 2009-02-26 22:12:32 PST
Wow, that's a nasty one!
Comment 2 Mark Rowe (bdash) 2009-02-26 22:12:44 PST
<rdar://problem/6629728>
Comment 3 mitz 2009-02-26 22:31:02 PST
The problem appears to be specific to the version of Geneva used on the webpage.
Comment 4 Mark Rowe (bdash) 2009-02-26 22:31:38 PST
I'm not sure that this is a regression any more as I realised that I wasn't testing what I thought I was testing.
Comment 5 Mark Rowe (bdash) 2009-02-26 22:33:08 PST
It's probably a violation of the license of the font to be redistributing it like this.  The font even says © Apple.
Comment 6 Eli Loewen 2009-02-27 08:08:09 PST
(In reply to comment #5)
> It's probably a violation of the license of the font to be redistributing it
> like this.  The font even says © Apple.

I never really thought of it as a violation, I think I just got the font from the internet somewhere.

But even if it is a violoation, it seems there is still a bug here.
Comment 7 Cameron Zwarich (cpst) 2009-02-27 08:48:50 PST
Created attachment 28072 [details]
Console output of GCGetGlyphIdealMetrics errors
Comment 8 Cameron Zwarich (cpst) 2009-02-27 08:58:51 PST
Created attachment 28073 [details]
Reduction

Here's a simple reduction using the copy of the font on his page.
Comment 9 Eli Loewen 2009-03-06 09:12:23 PST
So has anyone made any progress on this?

BTW, This font works perfectly in Gecko 1.9.1.
Comment 10 Cameron Zwarich (cpst) 2009-03-06 09:47:44 PST
Dan is probably the one to fix this bug, but since it is a regression I could try to find the point of regression.
Comment 11 Mark Rowe (bdash) 2009-03-06 09:50:36 PST
Do we have any evidence that this is a regression?  The only comment about that is from me saying I don't think it is.
Comment 12 Cameron Zwarich (cpst) 2009-03-06 09:58:56 PST
(In reply to comment #11)
> Do we have any evidence that this is a regression?  The only comment about that
> is from me saying I don't think it is.

Both the site and my reduction work fine for me in Safari 3.2 Do they not work for you?
Comment 13 Eli Loewen 2009-03-06 14:43:11 PST
(In reply to comment #12)
> (In reply to comment #11)
> > Do we have any evidence that this is a regression?  The only comment about that
> > is from me saying I don't think it is.
> 
> Both the site and my reduction work fine for me in Safari 3.2 Do they not work
> for you?
> 
It all works fine for me in Safari 3.2.
Comment 14 Eli Loewen 2009-03-10 17:21:03 PDT
Does anyone know what component this bug is related to so we are able to take it out of "New Bugs"?
Comment 15 Mark Rowe (bdash) 2009-03-10 17:22:33 PDT
There's no problem with it being in the New Bugs component.
Comment 16 Eli Loewen 2009-03-10 17:27:51 PDT
(In reply to comment #15)
> There's no problem with it being in the New Bugs component.
> 
True, its just not very specific.
Comment 17 mitz 2014-08-30 16:27:22 PDT
The bug no longer occurs (tested with Safari 7.0.6 on OS X 10.9.4).