Bug 24176 - "Cache-Control: public" doesn't save content to disk for SSL site
Summary: "Cache-Control: public" doesn't save content to disk for SSL site
Status: RESOLVED DUPLICATE of bug 24159
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: https://trial.rallydev.com/slm/
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-25 16:16 PST by Tarun Reddy
Modified: 2009-02-25 16:19 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tarun Reddy 2009-02-25 16:16:29 PST
Firefox 3+, Chrome and IE all store content that has a Response Header of 
Cache-Control: public
in the browser disk cache so that repeated visits to the same site (such as a Web 2.0 SaaS service) results in much faster load times. Safari is the only browser that does not respect this control. This includes Safari 3.2+ and Safari alpha 4.0+ on Mac OS X and Windows. This seems like a trivial change (but could be more complicated than I think) and would mimic behavior of all other major browsers.

The URL https://trial.rallydev.com/slm/ has the appropriate headers set for static content.
To reproduce:
1) With clean cache, visit  https://trial.rallydev.com/slm/ in Firefox and Safari
2) Notice in Inspector and Firebug that all static content includes the header "Cache-Control: max-age=86401, public" or "Cache-Control: public"
3) Quit browsers and restart browsers. Visit https://trial.rallydev.com/slm/ again.
4) Notice in Inspector that Safari downloads all components again, while Firefox (correctly) only downloads the dynamic content

See following URLs for more info:
http://blog.pluron.com/2008/07/why-you-should.html
http://blog.httpwatch.com/2009/01/15/https-performance-tuning/ (Tip #3)
Comment 1 Tarun Reddy 2009-02-25 16:19:45 PST
Sorry... didn't think my original went through. Apparently just got the email from the original so I'm closing this as a duplicate.

*** This bug has been marked as a duplicate of 24159 ***